FZU2264 Card Game (First Edition)(数论&规律)

Fat brother and Maze are playing a kind of special (hentai) game with some cards. There are N*2 cards in this game for the players to use, this is the card deck. The game goes for N rounds and in each round, Fat Brother would draw one card from the remaining card deck randomly and then Maze would draw one card from the remaining card deck randomly. Then they compare for the integers which is written on these two cards. The player with the higher number wins this round and score 1 victory point. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the expect number of the victory points he could get if he knows all the integers written in these cards.

Note that the integers written on these N*2 cards are pair wise distinct. At the beginning of this game, each player has 0 victory point.

Input

The first line of the data is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <= N<=10000) which described before. Then follow one line with N*2 integers, which indicate the integers in these cards.

All the integers are positive and no morethan 10000000.

Output

For each case, output the case number first, and then output the expect number of the victory points Fat Brother could get in this game. The answer should be rounded to 2 digits after the decimal point.

Sample Input
2
1
1 2
2
1 2 3 4
Sample Output
Case 1: 0.50
Case 2: 1.00


题意:胖兄和妹子玩卡牌游戏,桌上一共有2*n张牌,已知了这些牌都是哪些点数,任意两张牌的点数互不相同。玩n轮游戏,每轮游戏二人先后从这2*n张牌里抽取一张牌,抽取过的牌以后的每轮都不会被抽取,每轮谁抽的点数大谁赢。现在胖兄想知道这n轮游戏他获胜的数学期望是多少。


解题思路:

感谢老铁kangzzz的思路(双击666

在已知牌的点数和任意两张牌互不相同的情况下,两人都是随机抽取的,所以每轮要么是胖兄赢要么是妹子赢。每轮赢的概率是0.5,n轮赢的分的期望就是E=1*0.5+1*0.5+1*0.5+···+1*0.5(n个1*0.5,1表示每轮赢1分,0.5表示每轮赢的概率)不用计算,n局游戏两人都各赢一半我也忘了什么是数学期望反正感觉就是这样ε=ε=ε=(~ ̄▽ ̄)~


AC代码:

#include<stdio.h>

int main()
{
	int t,tt=1,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		int x;
		for(int i=0;i<2*n;i++)//注意是2*n张牌= = 
		{
			scanf("%d",&x);
		}
		printf("Case %d: ",tt++);
		printf("%.2f\n",n/2.0);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值