FZU-Problem 2150 Fire Game

Problem 2150 Fire Game

Accept: 392 Submit: 1502
Time Limit: 1000 mSec Memory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

43 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2
 
//两个点的bfs ,因为n和m比较小,所以可以用枚举任意两个点的方式求得最小值。
用d[n][m]表示在这个点的最小步数,首先初始为无穷大,然后遍历时用小于他的值去更新他,就是感觉这个数组很关键。每次遍历都要返回一个值,如果是inf'表示没有便利完。
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 10000
struct point
{
    int a,b;
};
int n,m,d[11][11],dir[4][2]={-1,0,1,0,0,1,0,-1};
char map[11][11];
int bfs(point x,point y)
{
    queue<point>q;
    point t,tt;
    q.push(x);q.push(y);
    memset(d,inf,sizeof(d));
    d[x.a][x.b]=0; d[y.a][y.b]=0;
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            tt.a=t.a+dir[i][0];
            tt.b=t.b+dir[i][1];
            if(tt.a>=0&&tt.a<n&&tt.b>=0&&tt.b<m&&map[tt.a][tt.b]=='#'&&d[tt.a][tt.b]>d[t.a][t.b]+1)
            {
                d[tt.a][tt.b]=d[t.a][t.b]+1;
                q.push(tt);
            }
        }
    }
    int res=0;   //每次枚举两个点,遍历完后,如果有点没有遍历到,那 res肯定等于inf
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            //printf("%d ",d[i][j]);
            if(map[i][j]=='#')
        res=max(res,d[i][j]);
        }
        //printf("\n");
    }
    return res;
}

int main()
{
    //freopen("a.txt","r",stdin);
    int t,cas=1;
    point s1,s2;
    scanf("%d",&t);
    while(t--)
    {
        int count=0;
        scanf("%d%d",&n,&m);
        getchar();
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
            //printf("%s\n",map[i]);
            for(int j=0;j<m;j++)
                if(map[i][j]=='#') count++;
        }
        printf("Case %d: ",cas++);
        if(count<=2)
        {
            printf("0\n");
            continue;
        }
        int cnt=inf;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(map[i][j]=='#')
                {
                    for(int l=0;l<n;l++)
                    {
                        for(int k=0;k<m;k++)
                        {
                        if(l<i&&k<=j) continue;
                        if(map[l][k]=='#')
                        {
                        s1.a=i;s1.b=j;s2.a=l;s2.b=k;
                        int ans=bfs(s1,s2);
                        cnt=min(ans,cnt);
                        }
                        }
                    }
                }
            }
        }
        if(cnt==inf) printf("-1\n");  //如果枚举任意两个点 cnt都是inf输入-1
        else printf("%d\n",cnt);
    }
    return 0;
}

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值