FZU2265 Card Game (Second Edition)(数论&规律)

Fat brother and Maze are playing a kind of special (hentai) game with some cards. In this game, every player gets N cards at first and these are their own card deck. The game goes for N rounds and in each round, Fat Brother and Maze would draw one card from their own remaining card deck randomly and compare for the integer which is written on the cards. The player with the higher number wins this round and score 1 victory point. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the expect number of the victory points he could get if he knows all the integers written in these cards.

Note that the integers written on these N*2 cards are pair wise distinct. At the beginning of this game, each player has 0 victory point.

Input

The first line of the data is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <=N<=10000) which described before. Then follow two lines with N integers each. The first N integers indicate Fat Brother’s cards and the second N integers indicate Maze’s cards.

All the integers are positive and no more than 10000000.

Output

For each case, output the case number first, and then output the expect number of victory points Fat Brother would gets in this game. The answer should be rounded to 2 digits after the decimal point.

Sample Input
2
1
1
2
2
1 3
2 4
Sample Output
Case 1: 0.00
Case 2: 0.50


题意:情境同上题,唯一不同的就是上题是2*n张牌放一起,这是分成了两堆,每堆n张牌。求胖兄赢的分数的数学期望。


解题思路:

感谢老铁hao817374(双击666

设胖兄的眼前的牌都有:1 2 7 8

妹子眼前的牌都有:3 4 5 6

那么对于胖兄来说,如果胖兄抽到了1,那么赢的点数就是0,抽到1的概率是1/n。

如果胖兄抽到了2,那么赢的点数就是0,抽到2的概率是1/n。

如果胖兄抽到了7,那么赢的点数就是4,抽到1的概率是1/n。

如果胖兄抽到了8,那么赢的点数就是4,抽到1的概率是1/n

期望就是0*1/n + 0*1/n + 4*1/n + 4*1/n = 8/n =8/4 = 2.00(保留两位小数0.0)


所以就是找下胖兄的牌有多少张比妹子的牌大,找出大的情况数除以n即为结果

AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;

int a[10010],b[10010];

int main()
{
	int t,tt=1,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		for(int i=0;i<n;i++)
		{
			scanf("%d",&b[i]);
		}
		sort(a,a+n);
		sort(b,b+n);
		int cnt=0;
		for(int i=0;i<n;i++)
		{
			cnt+=upper_bound(b,b+n,a[i])-b;
		}
		printf("Case %d: ",tt++);
		printf("%.2f\n",(double)cnt/n);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值