Problem 2265 Card Game (Second Edition) (数学期望)

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game with some cards. In this game, every player gets N cards at first and these are their own card deck. The game goes for N rounds and in each round, Fat Brother and Maze would draw one card from their own remaining card deck randomly and compare for the integer which is written on the cards. The player with the higher number wins this round and score 1 victory point. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the expect number of the victory points he could get if he knows all the integers written in these cards.

Note that the integers written on these N*2 cards are pair wise distinct. At the beginning of this game, each player has 0 victory point.

Input

The first line of the data is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <=N<=10000) which described before. Then follow two lines with N integers each. The first N integers indicate Fat Brother’s cards and the second N integers indicate Maze’s cards.

All the integers are positive and no more than 10000000.

Output

For each case, output the case number first, and then output the expect number of victory points Fat Brother would gets in this game. The answer should be rounded to 2 digits after the decimal point.

 Sample Input

2

1

1

2

2

1 3

2 4

 Sample Output

Case 1: 0.00

Case 2: 0.50

 Source

第七届福建省大学生程序设计竞赛-重现赛(感谢承办方闽江学院)

题意:两个人随机在自己牌中取一张比较,数值大的分数+1,求胖兄弟分数的数学期望。

数学公式:

Xk表示对手所有牌中有Xk张牌比胖兄弟的第k张牌小;

p表示每张牌拿到的概论,这题每张牌的概率都是1/n;

XkPk 为第k张牌的得分期望,累加n张牌的得分期望就是胖兄弟分数的数学期望;

AC代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int N = 10005;
int F[N];
int M[N];
int BinSearch(int sta,int end,int key)//二分查找求比key小的牌的数量 
{
	while(sta<=end) 
	{
		int mid=(sta+end)>>1;
		if(M[mid]==key)
			return mid;
		if(M[mid]>key)
			end=mid-1;
		else
			sta=mid+1;
	}
	return sta;  
}
int main()
{
	int T;
	scanf("%d",&T);
	for(int id=1;id<=T;id++)
	{
		int n,i;
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&F[i]);
		for(i=0;i<n;i++)
			scanf("%d",&M[i]);
		sort(M,M+n);
		double sum=0.0;
		for(i=0;i<n;i++)
			sum+=double(BinSearch(0,n,F[i]))/n;//累加每张牌的得分期望 
		printf("Case %d: %.2lf\n",id,sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值