POJ2377 Bad Cowtractors(最大生成树Prim&Kruskal)

142 篇文章 3 订阅

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".
Input
* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output
* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
Sample Input
5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17
Sample Output
42
Hint
OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.


题意:给出n和m表示n个顶点m条边。让你构造最大生成树并输出树的权值,如果构造不了就输出-1


解题思路:

Prim判断不能构造的条件:if(maxx==-INF)

Kruskal判读不能构造的条件是最后所有点不止一个祖先(不在一个共同的集合中)



AC代码:

Prim:

#include<stdio.h>
#include<string.h>

#define INF 0x3f3f3f3f

int mp[1010][1010],book[1010],dis[1010],n;

void prim()
{
	int sum=0;
	for(int i=1;i<=n;i++)
	{
		dis[i]=mp[1][i];
	}
	dis[1]=0;
	book[1]=1;
	for(int i=1;i<=n-1;i++)
	{
		int maxx=-INF,u;
		for(int j=1;j<=n;j++)
		{
			if(dis[j]>maxx&&book[j]==0)
			{
				maxx=dis[j];
				u=j;
			}
		}
		if(maxx==-INF)
		{
			printf("-1\n");
			return;
		}
		sum+=maxx;
		book[u]=1;
		for(int j=1;j<=n;j++)
		{
			if(mp[u][j]>dis[j]&&book[j]==0)
			{
				dis[j]=mp[u][j];
			}
		}
	}
	printf("%d\n",sum);
}

int main()
{
	int m;
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=1;i<=n;i++)
		{
			dis[i]=-INF;
			for(int j=1;j<=n;j++)
			{
				if(i==j) mp[i][j]=0;
				else mp[i][j]=mp[j][i]=-INF;
			}
		}
		memset(book,0,sizeof(book));
		
		int u,v,w;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&u,&v,&w);
			if(w>mp[u][v]) mp[u][v]=mp[v][u]=w;
		}
		prim();
	}
	return 0;
}


Kruskal:

#include<stdio.h>
#include<algorithm>
using namespace std;

struct edge
{
	int u,v,w;
} e[20010];

int f[20010],n,m;

int cmp(edge a,edge b)
{
	return a.w<b.w;
}

int getf(int v)
{
	if(f[v]==v) return v;
	else
	{
		f[v]=getf(f[v]);
		return f[v];
	}
}

int merge(int v,int u)
{
	int t1=getf(v);
	int t2=getf(u);
	if(t1!=t2)
	{
		f[t2]=t1;
		return 1;
	}
	return 0;
}

int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		int count=0,sum=0;
		for(int i=1;i<=n;i++)
			f[i]=i;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);
			e[i].w=-e[i].w;
		}
		sort(e+1,e+m+1,cmp);
		for(int i=1;i<=m;i++)
		{
			if(merge(e[i].u,e[i].v))
			{
				count++;
				sum+=e[i].w;
			}
			if(count==n-1) break;
		}
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			if(f[i]==i) ans++;
		}
		if(ans==1) printf("%d\n",-sum);
		else printf("-1\n");
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值