ZOJ 1940 Dungeon Master


ZOJ Problem Set - 1940
Dungeon Master

Time Limit: 2 Seconds      Memory Limit: 65536 KB

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?


Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).

L is the number of levels making up the dungeon.

R and C are the number of rows and columns making up the plan of each level.

Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.


Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.

If it is not possible to escape, print the line

Trapped!


Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0


Sample Output

Escaped in 11 minute(s).
Trapped!

#include<iostream>
#include<cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=35;
int d[6][3]={{0,1,0},{0,-1,0,},{1,0,0},{-1,0,0},{0,0,-1},{0,0,1}};
int vis[maxn][maxn][maxn],map[maxn][maxn][maxn];
int v,n,m;
struct  point
{
	int x,y,z;
	int dis;
};
queue<point>q;
int  bfs(point p)
{
	q.push(p);
	while(!q.empty())
	{
		point u=q.front();
		point next;
		q.pop();
		int a=u.x;
		int b=u.y;
		int c=u.z;
		for(int i=0;i<6;i++)
		{
			int newa=a+d[i][0];
			int newb=b+d[i][1];
			int newc=c+d[i][2];
			if(newa>=0&&newa<n&&newb>=0&&newb<m&&newc>=0&&newc<v&&!vis[newc][newa][newb])
			{
				if(map[newc][newa][newb]==1)
				{
					vis[newc][newa][newb]=1;
					next.x=newa;
					next.y=newb;
					next.z=newc;
					next.dis=u.dis+1;
					q.push(next);
				}
				if(map[newc][newa][newb]==2)
				{
					next.dis=u.dis+1;
					return next.dis;
				}
			}
		}
	}
	return -1;
}
int main()
{
	char ch;
	while(scanf("%d%d%d",&v,&n,&m)&&v&&n&&m)
	{
		while(!q.empty())
			q.pop();
		point start;
		memset(vis,0,sizeof(vis));
		for(int i=0;i<v;i++)
		{
			for(int j=0;j<n;j++)
			{
				for(int k=0;k<m;k++)
				{
					cin>>ch;
					if(ch=='#')
						map[i][j][k]=0;
					if(ch=='.')
						map[i][j][k]=1;
					if(ch=='S')
					{
						start.z=i;
						start.x=j;
						start.y=k;
						start.dis=0;
						vis[i][j][k]=1;
					}
					if(ch=='E')
					{
					   map[i][j][k]=2;
					}
				}
			}
		}
		int ans=bfs(start);
		if(ans!=-1)
		{
			printf("Escaped in %d minute(s).\n",ans);
		}
		else
		{
			printf("Trapped!\n");
		}
	}
	return 0;
}



Source: University of Ulm Local Contest 1997
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值