POJ 2488 A Knight's Journey(基础题)


A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30467 Accepted: 10431

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
思路:dfs
#include<cstring>
#include<queue>
#include<cstdio>
#include<map>
#include <vector>
#include<string>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=26;
int mapp[maxn*maxn],vis[maxn][maxn];
int d[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
int r,c;
bool dfs(int x,int y,int cur)
{
	mapp[cur]=x*c+y;
	if(cur==c*r-1)
	{
		return true;
	}
	for(int i=0;i<8;i++)
	{
		int newx=x+d[i][0];
		int newy=y+d[i][1];
		if(!vis[newx][newy]&&newx>=0&&newx<r&&newy>=0&&newy<c)
		{
			vis[newx][newy]=1;
			if(dfs(newx,newy,cur+1))
				return true;
			else vis[newx][newy]=0;
		}
	}
	return false;
}
int main()
{
	int T;
	while(scanf("%d",&T)!=EOF)
	{
		int cases=1;
		while(T--)
		{
			scanf("%d %d",&c,&r);
			int work=0;
			for(int i=0;i<r;i++)
			{
				for(int j=0;j<c;j++)
				{
				    memset(vis,0,sizeof(vis));
					vis[i][j]=1;
					if(dfs(i,j,0))
					{
						work=1;
						break;
					}
				}
				if(work) break;
			}
			cout<<"Scenario #"<<cases++<<":"<<endl;
			if(!work)
				cout<<"impossible"<<endl;
			else
			{
				for(int i=0;i<c*r;i++)
				{
					int x=mapp[i]/c;
					int y=mapp[i]%c;
					char ch='A'+x;
					int ans=y+1;
					cout<<ch<<ans;
				}
				cout<<endl;
			}
			cout<<endl;
		}
	}
	return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值