HDU 1019 Least Common Multiple(数论)

201 篇文章 10 订阅

Description
给出n个数,输出这n个数的最小公倍数
Input
第一行为用例组数T,每组用例占一行,首先输入一个整数n,之后输入n个整数
Output
对于每组用例,输出这n个数的最小公倍数
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
Solution
数据量不大,两两求最小公倍数即可
Code

#include<cstdio>
#include<iostream>
using namespace std;
int gcd(int x,int y)//求gcd(x,y) 
{
    if(x%y) return gcd(y,x%y);
    return y;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int now,next;
        scanf("%d",&now);
        for(int i=1;i<n;i++)
        {
            scanf("%d",&next);
            now=next/gcd(now,next)*now;     
        }
        printf("%d\n",now);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值