hdu1019

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66612    Accepted Submission(s): 25402


 

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
 

 

 

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

 

 

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

 

 

Sample Input

 

2 3 5 7 15 6 4 10296 936 1287 792 1

 

 

Sample Output

 

105 10296

 

题目大意:求n个数的最小公倍数

考点:两个数x和y,设x,y的最大公约数为p,最小公倍数为q,则:x*y=p*q。

求最大公约数p,就用辗转相除法就行。

ac代码:

#include<iostream>
using namespace std;
int arr[11];
int t,n;
int gcd(int a,int b){//两个方法任选一个
	if(b==0)
		return a;
	else
		return gcd(b,a%b);
}
int getGcd(int a,int b){
	int c;
	while(b){
		c=a;
		a=b;
		b=c%b;
	}
	return a;
}
int main(){
	while(cin>>t){
		while(t--){
			cin>>n;
	        for(int i=1;i<=n;i++){
	        	cin>>arr[i];
	        	if(i!=1){
		    	arr[i]=arr[i-1]/getGcd(arr[i-1],arr[i])*arr[i];
	     	    }
 	        } 
	         cout<<arr[n]<<endl;
		}
	}

} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值