HDU 1019 Least Common Multiple

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44912    Accepted Submission(s): 16871


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 
Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1
 
Sample Output
  
  
105 10296


题目的大意:先输入一个整数N,然后输入N组数,输入格式为M个和分别对应的M个具体的整数,最后求他们的最小公倍数。思想是从第一个到最后一个整数,从前往后两两求他们的最小公倍数。贴下自己AC的代码:

#include<iostream>
using namespace std;
int max_yue(long int x,long int y)
{
  long	int a=y,b=x;
	if(x%y==0)return y;
	else
	{
		x=a;
		y=b%a;
		max_yue(x,y);
	}
}
int main()
{
	int T,t;  //要判断几组和每组的个数 
	cin>>T;
	while(T--)
	{
	long	int sum=1;
	long	int a;
		cin>>t;
		while(t--) 
		{
			cin>>a;
			sum=sum/max_yue(sum,a)*a;             //之前提交两次没通过,因为之前写成 sum*a/max_yue(sum,a);先乘a可能会出现溢出的情况,要注意 
		}
		cout<<sum<<endl;
	 } 
	 return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值