CodeForces 112 A.Petya and Strings(水~)

Description

给出两个只有大小写字母的字符串a和b,问在不考虑字母的大小写情况下两个字符串的字典序大小

Input

两个等长的字符串a和b,串长不超过100

Output

如果a的字典序小于b则输出-1,等于则输出0,大于则输出1

Sample Input

aaaa
aaaA

Sample Output

0

Solution

水题,把两个字符串全部转化为小写字母后再比较即可

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
char deal(char c)
{
    if(c>='A'&&c<='Z')return c-'A'+'a';
    return c;
}
char a[maxn],b[maxn];
int main()
{
    while(~scanf("%s%s",a,b))
    {
        int n=strlen(a);
        for(int i=0;i<n;i++)
            a[i]=deal(a[i]),b[i]=deal(b[i]);
        printf("%d\n",strcmp(a,b));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值