GYM 100796 G.Robot Walk(水~)

253 篇文章 2 订阅

Description

给出一个长度为 n 的字符串,初始在p位置,给出一个长度为 m 的字符串表示操作序列,L表示左移一位, R 表示右移一位,输出经过位置上的字符,即一个长度为m+1的字符串

Input

第一行两个整数 n,p 表示字符串长度和起始位置,之后输入一个长度为 n 的字符串,然后输入一个整数m表示操作序列长度,最后输入一个长度为 m 的字符串表示操作序列(2n105,1xn,1m105),保证移动过程中不会移出字符串

Output

输出经过位置上的字符组成一个长度为 m+1 的字符串

Sample Input

7 1
taconut
10
RRRLRLRRRR

Sample Output

tacococonut

Solution

简单模拟

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
char s[maxn],t[maxn];
int n,m,p; 
int main()
{
    while(~scanf("%d%d",&n,&p))
    {
        scanf("%s%d%s",s,&m,t);
        printf("%c",s[--p]);
        for(int i=0;i<m;i++)
            if(t[i]=='R')printf("%c",s[++p]);
            else printf("%c",s[--p]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值