Description
有一棵 n n 个节点的树,每点有点权,先手可以取其中任意数量的点,只要这些点没有邻接点,其得分即为所选点的权值异或和,而后手的得分为剩余点的异或和,先手采取最佳策略,问谁赢
Input
第一行一整数表示用例组数,每组用例首先输入一个整数 n n 表示点数,之后输入个整数 wi w i 表示每点点权,最后 n−1 n − 1 行输入 n−1 n − 1 条树边
(1≤T≤20,1≤n≤105,0≤wi≤109) ( 1 ≤ T ≤ 20 , 1 ≤ n ≤ 10 5 , 0 ≤ w i ≤ 10 9 )
Output
Q Q 赢则输出, T T 赢则输出,平局则输出 D D
Sample Input
1
3
2 2 2
1 2
1 3
Sample Output
Q
Solution
考虑每点点权的异或和,若 res=0 r e s = 0 那么无论先手取的点集是什么,其点权异或和均等于剩余点集的点权异或和,此时是平局. 若 res>0 r e s > 0 ,考虑 res r e s 的最高位,显然有奇数个点在该位为 1 1 ,假设有个点,那么先手只要取其中 x+12 x + 1 2 个点即可获得比后手更大的点权异或和,且由于只取了一半的点,故一定存在任意两点不相邻的方案
Code
#include<cstdio>
using namespace std;
int T,n;
int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
int ans=0;
for(int i=1;i<=n;i++)
{
int a;
scanf("%d",&a);
ans^=a;
}
for(int i=1;i<n;i++)
{
int u,v;
scanf("%d%d",&u,&v);
}
if(ans)printf("Q\n");
else printf("D\n");
}
return 0;
}