Problem F. Grab The Tree HDU - 6324(思维+博弈)

Problem F. Grab The Tree HDU - 6324

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,…,n, connected by n−1 bidirectional edges. The i-th vertex has the value of wi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y, he can’t grab both x and y
. After Q’s move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices’ value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.
Input
The first line of the input contains an integer T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,…,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v, denoting a bidirectional edge between vertex u and v
.
Output
For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.
Sample Input

1
3
2 2 2
1 2
1 3

Sample Output

Q
题意:

在一棵树上有n个点,每个点有一个值,Q先取几个点,但是这些点不能相邻,也就是不能有连边,将这些点值异或得到一个值,剩下的点给T,他再异或得到一个值,谁大谁赢,否则平局。

分析:

这道题当时一看感觉是树形dp的模型。。(太丢人了),就瞎jb写,结果错了,改了改最后又和异或和判断一下阴差阳错就对了,但是赛后发现。。其实和上面写的dfs毫无关系,A完全是因为我们多了那个判断。。。。

如果所有点的异或和sum=0,那么无论Q怎么取得到的异或和,剩下的部分和Q的值一异或,最终结果一定为0,那么既然总的异或和为0,那么说明一定两个数相等,故一定平局。

如果sum != 0,那么我们考虑sum值最高位的1,既然最高位那个地方为1,说明n个点中,一定有奇数个点这个位为1,因为如果偶数个点这个位异或后肯定为0了,所以Q只需要只拿一个点,这一位为1,就可以赢,因为剩下的点异或后这一位肯定变成0了,一定比那一个数小。

所以要么平局要么Q赢

code:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 2e5+100;
int t,n,sum = 0;
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int temp;
        sum = 0;
        for(int i = 1; i <= n; i++){
            scanf("%d",&temp);
            sum ^= temp;
        }
        int v,u;
        for(int i = 1; i < n; i++){
            scanf("%d%d",&v,&u);
        }
        if(sum == 0) printf("D\n");
        else printf("Q\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值