PAT A1052 Linked List Sorting (25分)

PAT A1052 Linked List Sorting (25分)

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive N (<10^​5) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−10^​5​​ , 10^​5​​ ], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:
For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意:第一行给出节点个数你,以及首地址,接下来n行给出那个结点的地址,数据,下一结点的地址,输出要求按照结点数据从小到大排列,改变结点的地址链接成新的链表。
解析:题目是对静态链表的使用,设置一个结构体包括 address,data,next,以及设置一个flag;
这里需要注意的是
1、题目可能给出无效结点,因此需要flag来判断有效结点和无效结点
2、如果给出的首结点是空的,要直接输出“0 -1”;
3、输出时最后一个结点要单独输出,因为结点地址格式是“%05d”,如果地址是-1,输出会变成-0001

代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 100010;
struct Node
{
	int address;
	int data;
	int next;
	int flag;//有可能存在无效结点,因此需要flag该判断
}node[maxn];
bool cmp(Node a, Node b)
{
	if (a.flag == 0||b.flag==0)//如果结点是无效结点则排后
	{
		return a.flag > b.flag;
	}
	else
	{
		return a.data < b.data;
	}
}
int main()
{
	int n, ad;
	cin >> n >> ad;
	for (int i = 0; i < maxn; i++)
	{
		node[i].flag = 0;
	}
	int address;
	for (int i = 0; i < n; i++)
	{
		cin >> address;
		cin >> node[address].data >> node[address].next;
		node[address].address = address;
	}
	int p, count = 0;
	for (p = ad; p != -1; p = node[p].next)
	{
		node[p].flag = 1;
		count++;
	}
	if (count == 0)//特殊情况直接输出返回
	{
		cout << "0 -1" << endl;
		return 0;
	}
	sort(node, node + maxn, cmp);
	for (int i = 0; i < count - 1; i++)
	{
		node[i].next = node[i + 1].address;
	}
	node[count-1].next = -1;
	cout << count << " ";
	printf("%05d\n", node[0].address);
	for (int i = 0; i < count-1; i++)
	{
		printf("%05d %d %05d\n", node[i].address, node[i].data, node[i].next);
	}
	printf("%05d %d %d\n", node[count - 1].address, node[count - 1].data, node[count - 1].next);
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

VictorierJwr

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值