HDU Robberies

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.


Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .


Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.


Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05


Sample Output
2
4

6


这道题的大概题目是小偷被抓的最大概率是0.04,而小偷没偷一家,那么他被抓的概率就会上升,但是,很难判断他是真正被抓的概率,这里不是单纯的0.01+0.02什么的。

而是需要判断他被一家抓到还是被两家都抓到还是其他情况。这里就变得很麻烦。所以就需要逆着来想,就是判断他安全的概率1-P。抢一家成功就是1-p,两家就是

(1-p)(1-p),依次类推,抢越多家他的成功概率就越低,最后求不低与最大成功概率能够抢到的钱最多是多少。


#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<string>
#include<stack>
#include<deque>
#include<queue>
#include<list>
#include<set>
#include<map>
#include<cstdio>
#define mes(x) memset(x, 0, sizeof(x))
#define Pii pair<int, int>
#define Pll pair<ll, ll>
#define INF 1e9+7
typedef long long ll;
using namespace std;
const int MAX = 5000;
#define MOD 1000000007
//#define test
int main()
{
#ifdef test
    freopen("/home/ostreambaba/文档/input.txt", "r", stdin);
 // freopen("/home/ostreambaba/文档/input.txt", "w", stdout);
#endif
    int n;
    cin >> n;
    while(n--)
    {
        int count, money[1002], money_sum;
        double px, py, safe_prob[1002];
        cin >> px >> count;
        money_sum = 0;
        px = 1 - px;
        for(int i = 0; i < count; ++i)
        {
            cin >> money[i] >> py;
            safe_prob[i] = 1-py;
            money_sum += money[i];
        }
        double *dp = new double[money_sum+1]();
        dp[0] = 1;
        for(int i = 0; i < count; ++i)
            for(int j = money_sum; j >= money[i]; --j)
                dp[j] = max(dp[j], dp[j-money[i]]*safe_prob[i]);
        for(int i = money_sum; i >= 0; --i)//需要从最大钱数开始找,一直到第一个大与1-p的数就是1他抢的最多钱的数量
        {
            if(dp[i] >= px)
            {
                cout << i << endl;
                break;
            }
        }
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值