HDU3584 Cube(三维树状区间更新+位运算)

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1983    Accepted Submission(s): 1033


Problem Description
Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N). 
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].


Input
Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.


Output
For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)


Sample Input
2 5
1 1 1 1  1 1 1
0 1 1 1
1 1 1 1  2 2 2
0 1 1 1
0 2 2 2


Sample Output
1
0
1


Author
alpc32


Source
2010 ACM-ICPC Multi-University Training Contest(15)——Host by NUDT
简单题,三维数组,我们就在二维的基础上再加一位就好了。
这里我们求的是:
1.把空间上以(x1,y1,z1),(x2,y2,z2)为端点的区域所有的1变成00变成1.
2.求出(1,1,1)->(x,y,z)的区域的值.
这里用到异或,初始化立方体所在区域的值都为0,所以我们的异或值就要设置成为1,以后也是1.
然后就随便搞搞就行了,主要是区间的更新,安利一片好文章。

传送门

里面介绍的是2维的,三维的其实也同理,最后求得的值%2,由于这里是值为0,1,所以加不加都无所谓.
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cctype>
#include<cmath>
#include<ctime>
#include<string>
#include<stack>
#include<deque>
#include<queue>
#include<list>
#include<set>
#include<map>
#include<cstdio>
#include<limits.h>
#define MOD 1000000007
#define fir first
#define sec second
#define fin freopen("/home/ostreambaba/文档/input.txt", "r", stdin)
#define fout freopen("/home/ostreambaba/文档/output.txt", "w", stdout)
#define mes(x, m) memset(x, m, sizeof(x))
#define Pii pair<int, int>
#define Pll pair<ll, ll>
#define INF 1e9+7
#define Pi 4.0*atan(1.0)

#define lowbit(x) (x&(-x))
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

typedef long long ll;
typedef unsigned long long ull;
const double eps = 1e-12;
const int maxn = 3001;
using namespace std;

inline int read(){
    int x(0),op(1);
    char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')op=-1,ch=getchar();}
    while(ch>='0'&&ch<='9')x=x*10+ch-'0',ch=getchar();
    return x*op;
}
int N,Q;
int mat[101][101][101];
void update(int x,int y,int z,int val)
{
    for(int i=x;i<=N;i+=lowbit(i)){
        for(int j=y;j<=N;j+=lowbit(j)){
            for(int k=z;k<=N;k+=lowbit(k)){
                mat[i][j][k]^=val;
            }
        }
    }
}
int query(int x,int y,int z)
{
   int res=0;
   for(int i=x;i>0;i-=lowbit(i)){
       for(int j=y;j>0;j-=lowbit(j)){
           for(int k=z;k>0;k-=lowbit(k)){
               res^=mat[i][j][k];
           }
       }
   }
   return res;
}

int main()
{
   // fin;
    int x1,y1,z1,x2,y2,z2,c;
    while(~scanf("%d%d",&N,&Q)){
        mes(mat,0);
        while(Q--){
            scanf("%d%d%d%d",&c,&x1,&y1,&z1);
            if(c==1){
                scanf("%d%d%d",&x2,&y2,&z2);
                ++x2,++y2,++z2;
                update(x1,y1,z1,1);
                update(x1,y2,z2,1);
                update(x1,y1,z2,1);
                update(x1,y2,z1,1);
                update(x2,y2,z1,1);
                update(x2,y1,z2,1);
                update(x2,y2,z2,1);
                update(x2,y1,z1,1);
            }
            else{
                printf("%d\n",query(x1,y1,z1)%2);
            }
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值