hdu 3023 Dirt 优先队列&&bfs&&启发思路

-- Hello, may I speak to Petrov, please? Hello, my darling... You know, there was a little accident at our home... No, no, don't worry, your computer was not damaged. It is only a bit dirty there now. Well, I should say it's very dirty there and I'm at my Mom's now. Of course, I'll clean it... When? Well, maybe when I have my vacation. What? Well, when we are back from Turkey... the next vacation then. I'll stay at Mother's until then, and you may live here also. No, no, I don't insist, sure, you may stay at home if you wish so. I prepared boots for you, they are at the door. But please, don't make it worse, before you step on a clean floor, change your boots, put on your slippers, they are at the door also. Take them with you when you walk through the dirt. And when you walk on a clean floor, take the boots with you. You see, the dirt is in different places. OK, my love? Thank you! 

It is not a great pleasure to change boots each time you get from a clean floor to a dirty floor and vice versa, it's easier to walk extra several meters. So it is necessary to find a way of getting from one place in the apartment to another with the minimal possible number of boots changes; and among these paths the shortest one must be found. 

To begin with, it is natural to determine an optimal way of passing the Most Important Route: from the computer to the refrigerator.

Input

The first line of the input contains two integers M and N, which are dimensions of the apartment (in meters), 1 ≤ N, M ≤ 1000. The two integers in the second line are the coordinates of the computer, and the third line contains the coordinates of the refrigerator. Each of the following M lines contains N symbols; this is the plan of the apartment. On the plan, 1 denotes a clean square, 2 denotes a dirty square, and 0 is either a wall or a square of impassable dirt. It is possible to get from one square to another if they have a common vertex. When you pass from a clean square to a dirty one or vice versa, you must change shoes. The computer and the refrigerator are not on the squares marked with 0. 

The upper left square of the plan has coordinates (1, 1).

Output

You should output two integers in one line separated with a space. The first integer is the length of the shortest path (the number of squares on this path including the first and the last squares) with the minimal possible number of boots changes. The second number is the number of boots changes. If it is impossible to get from the computer to the refrigerator, you should output 0 0.

Sample Input

3 7
1 1
3 7
1200121
1212020
1112021

Sample Output

8 4

题意 0不能走 从1走到2或从2走到1要换鞋 找到最短路径且换鞋次数最少

题解:我一开始就是按照最普通的优先队列写的 后来发现不对 

原因大概是我的写法少了很多次更新

看了题解之后发现新写法 真的是妙啊 将vis标记写在前面 然后开设一个dis 和change数组实时更新 这样就会多很多次更新

受教了

#include <bits/stdc++.h>
#define maxn 1000+5
using namespace std;
char g[maxn][maxn];
int vis[maxn][maxn],dis[maxn][maxn],change[maxn][maxn];
int sx,sy,ex,ey,n,m;
struct node {
    int x,y,step,chan;
    operator >(const node &d)const{
        if(chan==d.chan)return step>d.step;
        return chan>d.chan;
    }
};
int dx[]={-1,-1,-1,0,1,1,1,0},dy[]={-1,0,1,1,1,0,-1,-1};
void bfs(){
    priority_queue<node,vector<node>,greater<node> >q;
    node now,next;
    now.x=sx,now.y=sy;
    now.chan=0,now.step=1;
    vis[now.x][now.y]=1;
    q.push(now);
    //cout<<233;
    while(!q.empty()){
        now=q.top();q.pop();
        vis[now.x][now.y]=1;
        if(now.x==ex&&now.y==ey){
            return ;
        }
        for(int i=0;i<8;i++){
            next.x=now.x+dx[i],next.y=now.y+dy[i];
            next.step=now.step+1;
            if(next.x>=0&&next.x<n&&next.y>=0&&next.y<m&&!vis[next.x][next.y]&&g[next.x][next.y]!='0'){
                if(g[next.x][next.y]!=g[now.x][now.y])next.chan=now.chan+1;
                else next.chan=now.chan;
                if (next.chan < change[next.x][next.y]||(next.chan==change[next.x][next.y]&&next.step<dis[next.x][next.y])){
                    change[next.x][next.y] = next.chan;
                    dis[next.x][next.y] = next.step;
                    q.push(next);
                }

            }
        }

    }
}
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        memset(vis,0,sizeof(vis));
        memset(change,0x3f,sizeof(change));
        memset(dis,0x3f,sizeof(dis));
        scanf("%d%d",&sx,&sy);sx--,sy--;
        scanf("%d%d",&ex,&ey);ex--,ey--;
        getchar();
        //cout<<233;
        for(int i=0;i<n;i++){
            scanf("%s",g[i]);
            //getchar();
        }
        bfs();
        //cout<<233;
        if(change[ex][ey]==0x3f3f3f3f)
            printf("0 0\n");
        else
        printf("%d %d\n",dis[ex][ey],change[ex][ey]);
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
对于HDU4546问题,还可以使用优先队列(Priority Queue)来解决。以下是使用优先队列的解法思路: 1. 首先,将数组a进行排序,以便后续处理。 2. 创建一个优先队列(最小堆),用于存储组合之和的候选值。 3. 初始化优先队列,将初始情况(即前0个数的组合之和)加入队列。 4. 开始从1到n遍历数组a的元素,对于每个元素a[i],将当前队列中的所有候选值取出,分别加上a[i],然后再将加和的结果作为新的候选值加入队列。 5. 重复步骤4直到遍历完所有元素。 6. 当队列的大小超过k时,将队列中的最小值弹出。 7. 最后,队列中的所有候选值之和即为前k小的组合之和。 以下是使用优先队列解决HDU4546问题的代码示例: ```cpp #include <iostream> #include <vector> #include <queue> #include <functional> using namespace std; int main() { int n, k; cin >> n >> k; vector<int> a(n); for (int i = 0; i < n; i++) { cin >> a[i]; } sort(a.begin(), a.end()); // 对数组a进行排序 priority_queue<long long, vector<long long>, greater<long long>> pq; // 最小堆 pq.push(0); // 初始情况,前0个数的组合之和为0 for (int i = 0; i < n; i++) { long long num = pq.top(); // 取出当前队列中的最小值 pq.pop(); for (int j = i + 1; j <= n; j++) { pq.push(num + a[i]); // 将所有加和结果作为新的候选值加入队列 num += a[i]; } if (pq.size() > k) { pq.pop(); // 当队列大小超过k时,弹出最小值 } } long long sum = 0; while (!pq.empty()) { sum += pq.top(); // 求队列中所有候选值之和 pq.pop(); } cout << sum << endl; return 0; } ``` 使用优先队列的方法可以有效地找到前k小的组合之和,时间复杂度为O(nklog(k))。希望这个解法对你有所帮助!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值