Dirt HDU - 3023 题解

– Hello, may I speak to Petrov, please? Hello, my darling… You know, there was a little accident at our home… No, no, don’t worry, your computer was not damaged. It is only a bit dirty there now. Well, I should say it’s very dirty there and I’m at my Mom’s now. Of course, I’ll clean it… When? Well, maybe when I have my vacation. What? Well, when we are back from Turkey… the next vacation then. I’ll stay at Mother’s until then, and you may live here also. No, no, I don’t insist, sure, you may stay at home if you wish so. I prepared boots for you, they are at the door. But please, don’t make it worse, before you step on a clean floor, change your boots, put on your slippers, they are at the door also. Take them with you when you walk through the dirt. And when you walk on a clean floor, take the boots with you. You see, the dirt is in different places. OK, my love? Thank you!

It is not a great pleasure to change boots each time you get from a clean floor to a dirty floor and vice versa, it’s easier to walk extra several meters. So it is necessary to find a way of getting from one place in the apartment to another with the minimal possible number of boots changes; and among these paths the shortest one must be found.

To begin with, it is natural to determine an optimal way of passing the Most Important Route: from the computer to the refrigerator.
Input
The first line of the input contains two integers M and N, which are dimensions of the apartment (in meters), 1 ≤ N, M ≤ 1000. The two integers in the second line are the coordinates of the computer, and the third line contains the coordinates of the refrigerator. Each of the following M lines contains N symbols; this is the plan of the apartment. On the plan, 1 denotes a clean square, 2 denotes a dirty square, and 0 is either a wall or a square of impassable dirt. It is possible to get from one square to another if they have a common vertex. When you pass from a clean square to a dirty one or vice versa, you must change shoes. The computer and the refrigerator are not on the squares marked with 0.

The upper left square of the plan has coordinates (1, 1).
Output
You should output two integers in one line separated with a space. The first integer is the length of the shortest path (the number of squares on this path including the first and the last squares) with the minimal possible number of boots changes. The second number is the number of boots changes. If it is impossible to get from the computer to the refrigerator, you should output 0 0.
Sample Input
3 7
1 1
3 7
1200121
1212020
1112021
Sample Output
8 4


一张图,从脏的地方到干净的地方或反过来都需要换鞋,求从a到b点换鞋次数最少的情况下的最小步数。
我用的优先队列懒惰入队的Dij做的,其实应该直接bfs就能做。
dij每次更新和当前点相连点到起点的最小值,这里就是枚举八方向更新最小值。

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<string>
#include<vector>
#include<algorithm>
#include<queue>
using namespace std;
int n, m;
int begx, begy, endx, endy;
string map[1005];
int dis[1005][1005];
int chang[1005][1005];
bool v[1005][1005];
struct point{
    int x, y, change, step;
    bool operator < (const point& b)const{
        if (change == b.change){ return step > b.step; }
        return change > b.change;
    }
};
priority_queue<point> que;

int dx[8] = { -1, -1, -1, 0, 0, 1, 1, 1 };
int dy[8] = { -1, 0, 1, -1, 1, -1, 0, 1 };
void dij(){
    while (!que.empty()){
        point cnt = que.top();
        que.pop();
        v[cnt.x][cnt.y] = 1;
        if (cnt.x == endx&&cnt.y == endy)break;
        for (int i = 0; i < 8; i++){
            point newp = { cnt.x + dx[i], cnt.y + dy[i], cnt.change, cnt.step + 1 };
            if (newp.x >= 0 && newp.x < n&&newp.y >= 0 && newp.y < m&&map[newp.x][newp.y]!='0'&&v[newp.x][newp.y] == 0){
                if (map[newp.x][newp.y] != map[cnt.x][cnt.y]){
                    newp.change++;
                }
                if (newp.change < chang[newp.x][newp.y]||(newp.change==chang[newp.x][newp.y]&&newp.step<dis[newp.x][newp.y])){
                    chang[newp.x][newp.y] = newp.change;
                    dis[newp.x][newp.y] = newp.step;
                    que.push(newp);
                }
            }
        }
    }
    while (!que.empty())que.pop();
}

int main(){
    while (~scanf("%d%d", &n, &m)){
        scanf("%d%d%d%d", &begx, &begy, &endx, &endy);
        begx--, begy--, endx--, endy--;
        for (int i = 0; i < n; i++){
            cin >> map[i];
        }
        memset(dis, 0x3f, sizeof(dis));
        dis[begx][begy] = 1;
        memset(chang, 0x3f, sizeof(chang));
        chang[begx][begy] = 0;
        memset(v, 0, sizeof(v));
        que.push({ begx, begy, 0, 1 });
        dij();

        if (chang[endx][endy] == 0x3f3f3f3f){ printf("0 0\n"); }
        else{ printf("%d %d\n", dis[endx][endy], chang[endx][endy]); }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值