poj 1470 Closest Common Ancestors(tarjan离线求lca)

Closest Common Ancestors
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 13257 Accepted: 4310

Description

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)

Input

The data set, which is read from a the std input, starts with the tree description, in the form:

nr_of_vertices
vertex:(nr_of_successors) successor1 successor2 ... successorn
...
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form:
nr_of_pairs
(u v) (x y) ...

The input file contents several data sets (at least one).
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.

Output

For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times
For example, for the following tree:

Sample Input

5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
      (2 3)
(1 3) (4 3)

Sample Output

2:1
5:5
 
题意:给出大量的询问,都是求两个结点的lca
思路:tarjan算法离线求出所有的lca。
 
AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <map>
#include <cstdlib>
#define L(rt) (rt<<1)
#define R(rt) (rt<<1|1)
#define ll long long
using namespace std;

const int maxn=905;

struct node
{
    int v,next;
} edge[maxn*2];
struct node1
{
    int v,next,id;
} que[500005];
int fa[maxn],G[maxn],Q[maxn],in[maxn],lca[500005],ans[maxn];
bool vis[maxn];
int n,q,num,numq;
void init()
{
    memset(G,-1,sizeof(G));
    memset(Q,-1,sizeof(Q));
    memset(in,0,sizeof(in));
    memset(vis,false,sizeof(vis));
    for(int i=1;i<=n;i++) fa[i]=i;
    num=numq=0;
}
void add(int u,int v)
{
    edge[num].v=v;
    edge[num].next=G[u];
    G[u]=num++;
}
void addq(int u,int v,int id)
{
    que[numq].v=v;
    que[numq].next=Q[u];
    que[numq].id=id;
    Q[u]=numq++;
}
int find_set(int x)
{
    return x==fa[x]?x:fa[x]=find_set(fa[x]);
}
void Union(int a,int b)
{
    int ra=find_set(a);
    int rb=find_set(b);
    if(ra!=rb) fa[rb]=ra;
}
void dfs(int u)
{
    vis[u]=true;
    for(int i=G[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        dfs(v);
        Union(u,v);
    }
    for(int i=Q[u]; i!=-1; i=que[i].next)
    {
        int v=que[i].v;
        if(vis[v]) lca[que[i].id]=find_set(v);
    }
}
int main()
{
    int a,b,k;
    char ch1[2],ch2[2];
    while(~scanf("%d",&n))
    {
        init();
        for(int i=1; i<=n; i++)
        {
            scanf("%d:(%d)",&a,&k);
            while(k--)
            {
                scanf("%d",&b);
                add(a,b);
                in[b]++;
            }
        }
        scanf("%d",&q);
        for(int i=1; i<=q; i++)
        {
            scanf("%1s%d%d%1s",ch1,&a,&b,ch2);
            addq(a,b,i);
            addq(b,a,i);
        }
        for(int i=1; i<=n; i++)
            if(!in[i])
            {
                dfs(i);
                break;
            }
        memset(ans,0,sizeof(ans));
        for(int i=1; i<=q; i++) ans[lca[i]]++;
        for(int i=1; i<=n; i++)
        if(ans[i]) printf("%d:%d\n",i,ans[i]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值