POJ - 1470 Closest Common Ancestors(LCA 离线tarjan)

Closest Common Ancestors

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)

Input

The data set, which is read from a the std input, starts with the tree description, in the form: 

nr_of_vertices 
vertex:(nr_of_successors) successor1 successor2 ... successorn 
... 
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form: 
nr_of_pairs 
(u v) (x y) ... 

The input file contents several data sets (at least one). 
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.

Output

For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times 
For example, for the following tree: 

Sample Input

5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
      (2 3)
(1 3) (4 3)

Sample Output

2:1
5:5

Hint

Huge input, scanf is recommended.

 

题目大意:给你n点树,要查询m次(u,v)的LCA,统计所有查询的LCA,记录其出现次数

思路:离线Tarjan模板题

离线Tarjan的具体实现不太好讲,但是照着模板自己在纸上模拟一遍就会很清楚了

反正我是看了几篇博客,都看不太懂,但是对着版子模拟一遍就突然清醒(当然也可能是我智硬的问题)

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
const int N=1000+20;
bool isroot[N],vis[N];
int q[N][N],ans[N],fa[N];
int root,n,m;
vector<int>e[N];
void init()
{
    mem(q,0);
    mem(ans,0);
    mem(fa,0);
    mem(isroot,1);
    mem(vis,0);
}
int find(int x)
{
    if(fa[x]==x) return x;
    return fa[x]=find(fa[x]);
}
void LCA(int u)
{
    for(int i=1;i<=n;i++)
        if(vis[i]&&q[u][i])
        ans[find(i)]+=q[u][i];
    vis[u]=1;
    for(int i=0;i<e[u].size();i++)
    {
        int tmp=e[u][i];
        LCA(tmp);
        fa[tmp]=u;
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=1;i<=n;i++) {fa[i]=i;e[i].clear();}
        int k,x,y;
        for(int i=1;i<=n;i++)
        {
            scanf("%d:(%d)",&x,&k);
            for(int i=0;i<k;i++)
            {
                scanf("%d",&y);
                isroot[y]=0;
                e[x].push_back(y);
            }
        }
        for(int i=1;i<=n;i++)
            if(isroot[i])
        {
            root=i;
            break;
        }
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            scanf(" (%d %d)",&x,&y);
            q[x][y]++;
            q[y][x]++;
        }
        LCA(root);
        for(int i=1;i<=n;i++)
            if(ans[i])
            printf("%d:%d\n",i,ans[i]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值