zoj 2059 The Twin Towers(DP)

The Twin Towers

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Twin towers we see you standing tall, though a building's lost our faith will never fall.
Twin towers the world hears your call, though you're gone it only strengthens our resolve.
We couldn't make it through this without you Lord, through hard times we come together more. ... 

Twin Towers - A Song for America

In memory of the tragic events that unfolded on the morning of September 11, 2001, five-year-old Rosie decids to rebuild a tallest Twin Towers by using the crystals her brother has collected for years. Will she succeed in building the two towers of the same height?


Input

There are mutiple test cases.

One line forms a test case. The first integer N (N < 100) tells you the number of crystals her brother has collected. Then each of the next N integers describs the height of a certain crystal.

A negtive N indicats the end.

Note that all crytals are in cube shape. And the total height of crystals is smaller than 2000.


Output

If it is impossible, you would say "Sorry", otherwise tell her the height of the Twin Towers.


Sample Input

4 11 11 11 11
4 1 11 111 1111 
-1


Sample Output

22
Sorry


题意:给出n个小塔,每个小塔都有一个高度,问能否利用这些小塔组成两个高度相等的塔(不一定要所有小塔都用完),若能,输出最大的高度。
思路:DP,背包思想。题目说了组成的塔高度小于2000,设dp[i][j]表示搜索到第i个高度、两塔高度差为j时,较高的塔的最大高度。
转移方程见代码:

AC代码:
#include <iostream>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <queue>
#include <stack>
#include <ctime>
#include <vector>
#include <algorithm>
#define ll __int64
#define L(rt) (rt<<1)
#define R(rt)  (rt<<1|1)

using namespace std;

const int INF = 2000000000;
const int maxn = 20005;
const int mod = 1e9;

int n;
int dp[105][2005], a[105];   //dp[i][j]表示搜索到第i个高度、两塔高度差为j时,较高的塔的最大高度
int main()
{
    while(scanf("%d", &n))
    {
        if(n < 0) break;
        int sum = 0;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
            sum += a[i];
        }
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++)
        {
            for(int j = 0; j <= sum; j++)
            {
                if(dp[i - 1][j])
                {
                    //加到较高的塔上
                    if(j + a[i] <= sum) dp[i][j + a[i]] = max(dp[i][j + a[i]], dp[i - 1][j] + a[i]);
                    //加到较低的塔上,较低的塔仍比高的低
                    if(j >= a[i]) dp[i][j - a[i]] = max(dp[i][j - a[i]], dp[i - 1][j]);
                    //加到较低的塔上,较低的塔变成较高的塔
                    else dp[i][a[i] - j] = max(dp[i][a[i] - j], dp[i - 1][j] + a[i] - j);
                }
            }
            dp[i][a[i]] = max(dp[i][a[i]], a[i]);
            for(int j = 0; j <= sum; j++) dp[i][j] = max(dp[i][j], dp[i - 1][j]); //可不取当前这个高度
        }
        if(dp[n][0]) printf("%d\n", dp[n][0]);
        else printf("Sorry\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值