poj 2923 Relocation(状态压缩+01背包)

52 篇文章 0 订阅
18 篇文章 0 订阅
Relocation
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1846 Accepted: 763

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers n, C1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3
 
题意:有n个货物,有两辆车,运载量分别是C1和C2,并且给出每件物品的体积,问用两辆车同时运载,要将全部货物运完,至少要运多少次。
思路:状态压缩+01背包。先生成所有能一次运完的状态,每个状态中位为1的表示这一次能将该位代表的货物运过去,判断时借助01背包。然后再进行一次01背包,dp[i]表示为运完状态i需要的次数,具体转移方程见代码。
 
 
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <algorithm>
#define ll long long

using namespace std;

const int INF = 1e9;
const int maxn = 10005;
const int mod = 100000000;

int n, c1, c2, cnt;
int w[15], sta[maxn], dp[maxn * 2];
bool vis[maxn];
bool ok(int x){                         //判断该状态能否一次运完
    int sum = 0;
    memset(vis, false, sizeof(vis));
    vis[0] = true;
    for(int i = 0; i < n; i++)           //01背包
    if(x & (1 << i))
    {
        sum += w[i];
        for(int j = c1; j >= w[i]; j--)          
        if(vis[j - w[i]]) vis[j] = true;
    }
    if(sum > c1 + c2) return false;
    for(int i = 0; i <= c1; i++)
    if(vis[i] && sum - i <= c2) return true;
    return false;
}
void init(){                           //生成所有可以一次运完的状态
    cnt = 0;
    for(int i = 0; i < (1 << n); i++)
    if(ok(i)) sta[cnt++] = i;
}
int main()
{
    int t, ca = 0;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d", &n, &c1, &c2);
        for(int i = 0; i < n; i++)
        scanf("%d", &w[i]);
        init();
        for(int i = 0; i < (1 << n); i++) dp[i] = INF;
        dp[0] = 0;
        for(int i = 0; i < cnt; i++)              //01背包
        for(int j = (1 << n) - 1; j >= 0; j--)
        if((sta[i] & j) == 0)
        dp[sta[i] | j] = min(dp[sta[i] | j], dp[j] + 1);
        printf("Scenario #%d:\n", ++ca);
        printf("%d\n\n", dp[(1 << n) - 1]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值