poj 2349 Arctic Network(最小瓶颈生成树)

17 篇文章 0 订阅
Arctic Network
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7323 Accepted: 2470

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13
 
题意:有p个前哨站,现在要建造一个无线网络,使得所有前哨站连通。连通每两个前哨战的花费为它们之间的距离。有s个前哨战拥有卫星通道,拥有卫星通道的前哨站之间能互相通信而不需要依靠无线网络。求连通所有前哨战所需的建造无线网络的花费。
思路:求最小瓶颈生成树,给出加权无向图,求一棵生成树,使得最大边权值尽量小。原图的最小生成树就是一棵最小瓶颈生成树。显然,拥有卫星通道的s个前哨站可以当作一个连通分量。只要连上这个连通分量的其中一个顶点即可。具体做法是先求原图的最小生成树,然后减去最长的s-1条边即可。
 
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>
#define max2(a,b) ((a) > (b) ? (a) : (b))
#define min2(a,b) ((a) < (b) ? (a) : (b))

using namespace std;
const double INF=10000000;

struct node
{
    double x,y;
}outpost[505];
int s,p;
double G[505][505];
double lowcost[505];
double MST[505];
bool vis[505];
double get_dis(node a,node b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double prim()
{
    int x,cnt=0;
    double m;
    memset(vis,false,sizeof(vis));
    for(int i=0;i<p;i++)
    lowcost[i]=G[0][i];
    vis[0]=true;
    for(int i=1;i<p;i++)
    {
        m=INF;
        for(int j=0;j<p;j++)
        if(!vis[j]&&lowcost[j]<m)
        m=lowcost[x=j];
        if(m==INF) break;
        MST[cnt++]=m;
        vis[x]=true;
        for(int j=0;j<p;j++)
        if(!vis[j]&&G[x][j]<lowcost[j])
        lowcost[j]=G[x][j];
    }
    sort(MST,MST+cnt);
    cnt-=(s-1);
    return MST[cnt-1];
}
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d",&s,&p);
        for(int i=0;i<p;i++)
        for(int j=0;j<p;j++)
        G[i][j]=INF;
        for(int i=0;i<p;i++)
        scanf("%lf%lf",&outpost[i].x,&outpost[i].y);
        for(int i=0;i<p;i++)
        for(int j=i+1;j<p;j++)
        G[i][j]=G[j][i]=get_dis(outpost[i],outpost[j]);

        printf("%.2f\n",prim());
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值