poj 1686 Lazy Math Instructor(表达式求值)

Lazy Math Instructor
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3307 Accepted: 1112

Description

A math instructor is too lazy to grade a question in the exam papers in which students are supposed to produce a complicated formula for the question asked. Students may write correct answers in different forms which makes grading very hard. So, the instructor needs help from computer programmers and you can help.

You are to write a program to read different formulas and determine whether or not they are arithmetically equivalent.

Input

The first line of the input contains an integer N (1 <= N <= 20) that is the number of test cases. Following the first line, there are two lines for each test case. A test case consists of two arithmetic expressions, each on a separate line with at most 80 characters. There is no blank line in the input. An expression contains one or more of the following:
  • Single letter variables (case insensitive).
  • Single digit numbers.
  • Matched left and right parentheses.
  • Binary operators +, - and * which are used for addition, subtraction and multiplication respectively.
  • Arbitrary number of blank or tab characters between above tokens.

Note: Expressions are syntactically correct and evaluated from left to right with equal precedence (priority) for all operators. The coefficients and exponents of the variables are guaranteed to fit in 16-bit integers.

Output

Your program must produce one line for each test case. If input expressions for each test data are arithmetically equivalent, "YES", otherwise "NO" must be printed as the output of the program. Output should be all in upper-case characters.

Sample Input

3
(a+b-c)*2
(a+a)+(b*2)-(3*c)+c
a*2-(a+c)+((a+c+e)*2)
3*a+c+(2*e)
(a-b)*(a-b)
(a*a)-(2*a*b)-(b*b)

Sample Output

YES
YES
NO
 
题意:给出两个表达式,求两个表达式最终的结果是否相等。
思路:字母可以直接化为ASCII码来计算,数字就用原来的值来计算。然后就是表达式求值。将中缀表达式转化为后缀表达式,以便求值。
      中缀表达式转换为后缀表达式详解
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <map>
#define max2(a,b) ((a) > (b) ? (a) : (b))
#define min2(a,b) ((a) < (b) ? (a) : (b))

using namespace std;
map<char,int>m;
string transform(string s)    //转化为后缀表达式
{
    int len=s.length();
    char c[100];
    int top=0;
    stack<char>exp;
    for(int i=0;i<len;i++)
    {
        if(isalnum(s[i])) c[top++]=s[i];
        else
        {
            switch(s[i])
            {
                case '(':
                       exp.push(s[i]);
                       break;
                case ')':
                       while(exp.top()!='(')
                       {
                        c[top++]=exp.top();
                       exp.pop();
                       }
                       exp.pop();
                       break;
                case '+':
                case '-':
                case '*':
                       while(!exp.empty()&&m[s[i]]<=m[exp.top()])
                       {
                           c[top++]=exp.top();
                           exp.pop();
                       }
                       exp.push(s[i]);
            }
        }
    }
    while(!exp.empty())
    {
        c[top++]=exp.top();
        exp.pop();
    }
    c[top]='\0';
    string temp=c;
    return temp;
}
int cal(string s)
{
    int len=s.length();
    stack<int>c;
    for(int i=0;i<len;i++)
    {
        if(isalnum(s[i]))
        {
            if(isdigit(s[i]))
            c.push(s[i]-'0');
            else
            c.push(s[i]);
        }
        else
        {
            int a=c.top();
            c.pop();
            int b=c.top();
            c.pop();
            switch(s[i])
            {
                case '+':c.push(b+a);
                         break;
                case '-':c.push(b-a);
                         break;
                case '*':c.push(b*a);
            }
        }
    }
    return c.top();
}
int main()
{
   int t;
   string s1,s2;
   m['(']=0;
   m['+']=m['-']=1;
   m['*']=2;
   cin>>t;
   getchar();
   while(t--)
   {
       getline(cin,s1);
       getline(cin,s2);
       string t1=transform(s1);
       string t2=transform(s2);
       int ans1=cal(t1);
       int ans2=cal(t2);
       if(ans1==ans2)
       cout<<"YES"<<endl;
       else
       cout<<"NO"<<endl;
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值