POJ 1686 Lazy Math Instructor (中缀表达式计算)

Lazy Math Instructor
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3819 Accepted: 1320

Description

A math instructor is too lazy to grade a question in the exam papers in which students are supposed to produce a complicated formula for the question asked. Students may write correct answers in different forms which makes grading very hard. So, the instructor needs help from computer programmers and you can help.

You are to write a program to read different formulas and determine whether or not they are arithmetically equivalent.

Input

The first line of the input contains an integer N (1 <= N <= 20) that is the number of test cases. Following the first line, there are two lines for each test case. A test case consists of two arithmetic expressions, each on a separate line with at most 80 characters. There is no blank line in the input. An expression contains one or more of the following:
  • Single letter variables (case insensitive).
  • Single digit numbers.
  • Matched left and right parentheses.
  • Binary operators +, - and * which are used for addition, subtraction and multiplication respectively.
  • Arbitrary number of blank or tab characters between above tokens.

Note: Expressions are syntactically correct and evaluated from left to right with equal precedence (priority) for all operators. The coefficients and exponents of the variables are guaranteed to fit in 16-bit integers.

Output

Your program must produce one line for each test case. If input expressions for each test data are arithmetically equivalent, "YES", otherwise "NO" must be printed as the output of the program. Output should be all in upper-case characters.

Sample Input

3
(a+b-c)*2
(a+a)+(b*2)-(3*c)+c
a*2-(a+c)+((a+c+e)*2)
3*a+c+(2*e)
(a-b)*(a-b)
(a*a)-(2*a*b)-(b*b)

Sample Output

YES
YES
NO

Source


大体题意:

每一组数据给你两个表达式,问两个表达式结果是否相同!

思路:

直接用红书的中缀表达式模板就可过了!

虽然是公式最后是否相等,可以随便数据看是否相同!,可以将每个字母弄成指定的ASCII码值!

直接计算即可!

注意:

表达式会有空格 但模板是支持空格的,所以直接gets即可!

保险点可以加个精度eps!

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
#include<vector>
#include<string>
#include<cstdlib>
#include<cctype>
#include<cmath>
#include<iostream>
using namespace std;
const double eps = 1e-8;
int priv[300];
double value[300];
double calc(double a,double b,char op){
    if (op == '+')return a + b;
    if (op == '-')return a - b;
    if (op == '*')return a * b;
    if (op == '/')return a / b;
}
double calculate(string str,double val[] = value){
    stack<double >num;
    stack<char > oper;
    priv['+'] = priv['-'] = 3;
    priv['*'] = priv['/'] = 2;
    priv['('] = 10;
    double x,y,t = 0;
    int i;char last = 0;
    for (i = 0; i < str.length(); i++){
        if (isalpha(str[i])){
            num.push(val[str[i]]);
        }else if (isdigit(str[i])){
            num.push(atof(str.c_str()+i));
            for (;i+1 < str.length()&&isdigit(str[i+1]);i++);
            if (i+1<str.length()&&str[i+1] == '.')
                for (i++;i+1<str.length()&&isdigit(str[i+1]);i++);
        }else if (str[i] == '('){
            oper.push(str[i]);
        }else if (str[i] == ')'){
            while(oper.top()!='('){
                y = num.top();num.pop();
                x = num.top();num.pop();
                char op=oper.top();
                oper.pop();
                num.push(calc(x,y,op));
            }
            oper.pop();
        }else if (str[i] == '-' && (last == 0||last == '(')){
            num.push(0.0);
            oper.push('-');
        }else if (priv[str[i]]>0){
            while(oper.size()>0&&priv[str[i]]>=priv[oper.top()]){
                y = num.top();num.pop();
                x = num.top();num.pop();
                char op = oper.top();
                oper.pop();
                num.push(calc(x,y,op));
            }
            oper.push(str[i]);
        }else continue;
        last = str[i];
    }
    while(oper.size()>0){
        y=num.top();num.pop();
        x=num.top();num.pop();
        char op = oper.top();
        oper.pop();
        num.push(calc(x,y,op));
    }
    return num.top();
}
int main(){
    for (int i = 0; i < 300; ++i)value[i] = i;
    int n;
    char u[300],v[300];
    scanf("%d",&n);
    getchar();
    while(n--){
        gets(u);
        gets(v);
        double ans1 = calculate(u);
        double ans2 = calculate(v);
        if (fabs(ans1-ans2) < eps)printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值