hdu 3074 Multiply game(线段树模版)

Multiply game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1093    Accepted Submission(s): 358


Problem Description
Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…

 

Input
The first line is the number of case T (T<=10).
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an, 
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n) 
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.
 

Output
For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
 

Sample Input
  
  
1 6 1 2 4 5 6 3 3 0 2 5 1 3 7 0 2 5
 

Sample Output
  
  
240 420
题意:给出n个数,有m个操作,操作有:询问区间[L,R]中所有数的成绩、改变某一个数的值。
思路:线段树模版题。在每个结点设一个值保存乘积。
AC代码:
#include <iostream>
#include <algorithm>
#include <queue>
#include <cstring>
#include <cstdio>
#define L(rt) (rt<<1)
#define R(rt)  (rt<<1|1)
using namespace std;

const int mod=1000000007;
const int N=50005;
int  num[N];

struct node
{
    int l,r;
    long long ans;
}tree[N*4];

void build(int l,int r,int rt)
{
    tree[rt].l=l;
    tree[rt].r=r;
    if(l==r)
    {
        tree[rt].ans=num[l];
        return;
    }
    int mid=(l+r)>>1;
    build(l,mid,L(rt));
    build(mid+1,r,R(rt));
    tree[rt].ans=(tree[L(rt)].ans*tree[R(rt)].ans)%mod;
}
long long query(int l,int r,int rt)
{
    if(tree[rt].l==l&&tree[rt].r==r)
    return tree[rt].ans;
    int mid=(tree[rt].l+tree[rt].r)>>1;
    if(r<=mid)
    return query(l,r,L(rt));
    else if(l>=mid+1)
    return query(l,r,R(rt));
    else
    {
        long long a=query(l,mid,L(rt));
        long long b=query(mid+1,r,R(rt));
        return (a*b)%mod;
    }
}
void update(int val,int loc,int rt)
{
    if(tree[rt].l==loc&&tree[rt].r==loc)
    {
        tree[rt].ans=val;
        return;
    }
    if(loc<=tree[L(rt)].r)
    update(val,loc,L(rt));
    if(loc>=tree[R(rt)].l)
    update(val,loc,R(rt));
    tree[rt].ans=(tree[L(rt)].ans*tree[R(rt)].ans)%mod;
}
int main()
{
    //freopen("1.txt","r",stdin);
    int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        scanf("%d",&num[i]);
        build(1,n,1);
        scanf("%d",&m);
        int op,x,y;
        while(m--)
        {
            scanf("%d%d%d",&op,&x,&y);
            if(op==0)
            {
                long long ans=query(x,y,1);
                printf("%lld\n",ans%mod);
            }
            else
            update(y,x,1);
        }          
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值