hdu 1394 Minimum Inversion Number(树状数组求逆序数)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6925    Accepted Submission(s): 4232


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
题意:给出长度为n的数列,数列可以变形为:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
在上面的数列中找逆序数最小的,并输出最小的逆序数
思路:树状数组求逆序数。每加入一个数num[i](注意要将所有元素+1),新增的逆序数为已插入数组中的数-比num[i]小的数。先求出原始数列的逆序数,以后每把前面的一个元素移到后面,逆序数新增n-num[i]个,减少num[i]-1个。
AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>
#define max2(a,b) ((a) > (b) ? (a) : (b))
#define min2(a,b) ((a) < (b) ? (a) : (b))

using namespace std;
const int N=5050;
int n;
int c[N],num[N];
int lowbit(int x)
{
    return x&(-x);
}
void modify(int x,int d)
{
    for(int i=x;i<=n;i+=lowbit(i))
    c[i]+=d;
}
int sum(int x)
{
    int ret=0;
    for(int i=x;i>0;i-=lowbit(i))
        ret+=c[i];
    return ret;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        int Sum=0;
        memset(c,0,sizeof(c));    //不记得初始化,wa了n次- -
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            num[i]++;
            Sum+=sum(n)-sum(num[i]);
            modify(num[i],1);
        }
        int min=Sum;
        for(int i=1;i<=n;i++)
        {
            Sum+=n-num[i]-(num[i]-1);
            min=min2(Sum,min);
        }
        printf("%d\n",min);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值