hdu 4313 Matrix(最大生成树)

17 篇文章 0 订阅

Matrix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1835    Accepted Submission(s): 703


Problem Description
Machines have once again attacked the kingdom of Xions. The kingdom of Xions has N cities and N-1 bidirectional roads. The road network is such that there is a
unique path between any pair of cities.

Morpheus has the news that K Machines are planning to destroy the whole kingdom. These Machines are initially living in K different cities of the kingdom and
anytime from now they can plan and launch an attack. So he has asked Neo to destroy some of the roads to disrupt the connection among Machines. i.e after destroying those roads there should not be any path between any two Machines.

Since the attack can be at any time from now, Neo has to do this task as fast as possible. Each road in the kingdom takes certain time to get destroyed and they
can be destroyed only one at a time. 

You need to write a program that tells Neo the minimum amount of time he will require to disrupt the connection among machines.
 

Input
The first line is an integer T represents there are T test cases. (0<T <=10)
For each test case the first line input contains two, space-separated integers, N and K. Cities are numbered 0 to N-1. Then follow N-1 lines, each containing three, space-separated integers, x y z, which means there is a bidirectional road connecting city x and city y, and to destroy this road it takes z units of time.Then follow K lines each containing an integer. The ith integer is the id of city in which ith Machine is currently located.
2 <= N <= 100,000
2 <= K <= N
1 <= time to destroy a road <= 1000,000
 

Output
For each test case print the minimum time required to disrupt the connection among Machines.
 

Sample Input
  
  
1 5 3 2 1 8 1 0 5 2 4 5 1 3 4 2 4 0
 

Sample Output
  
  
10
Hint
Neo can destroy the road connecting city 2 and city 4 of weight 5 , and the road connecting city 0 and city 1 of weight 5. As only one road can be destroyed at a time, the total minimum time taken is 10 units of time. After destroying these roads none of the Machines can reach other Machine via any path.
 

题意:给出n个点,n-1条边,给出k个点,要使这k个点互不相连,要求删除最小权值的边,输出删除的边的权值总和。
思路:生成k课最大生成树,删除k-1条边。用kruskal算法。

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <cstdlib>
using namespace std;

const int maxn=100005;
struct node
{
    int u,v,w;
} edge[maxn];
int n,k;
int fa[maxn];
bool loc[maxn];
bool cmp(node a,node b)
{
    return a.w>b.w;
}
void init()
{
    for(int i=0; i<n; i++)
        fa[i]=i;
    memset(loc,false,sizeof(loc));
}
int Find_set(int x)
{
    if(x==fa[x]) return fa[x];
    fa[x]=Find_set(fa[x]);
    return fa[x];
}
void Union(int ra,int rb)
{
    if(loc[ra])
    fa[rb]=ra;
    else
    fa[ra]=rb;
}
int main()
{
    int t,a;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        init();
        for(int i=0; i<n-1; i++)
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
        while(k--)
        {
            scanf("%d",&a);
            loc[a]=true;
        }
        sort(edge,edge+n-1,cmp);
        long long ans=0;
        for(int i=0; i<n-1; i++)
        {
            int x=Find_set(edge[i].u);
            int y=Find_set(edge[i].v);
            if(loc[x]&&loc[y])
                ans+=edge[i].w;
            else
                Union(x,y);
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值