K11999 stack or queue

11 篇文章 0 订阅
9 篇文章 0 订阅

题目描述

栈和队列都是常用的线性结构,它们都提供两个操作:

Push:加入一个元素。

Pop:弹出一个元素。

不同的是,栈是”先进后出”,而队列则是”先进先出”。

给出一个线性结构的进出顺序,判定这个结构是栈还是队列。

输入格式

第一行输入一个整数T,代表有T组测试数据,T<=20

对于每组测试数据:

第一行,一个整数n,代表操作的次数。3<=n<=2000

接下来n行,每行包含两个整数 type val。当type = 1时,表示该次操作为push操作,val表示进入的数字。当type=2时,表示该次操作为pop操作,val代表出来的数字。

输出格式

每组测试数据输出一行。

输出改组数据对应的线性结构,”Stack” 或者 “Queue”。

题目保证是栈或者队列的一种。

输入输出样例

输入样例1:
2
6
1 1
1 2
1 3
2 3
2 2
2 1
4
1 1
1 2
2 1
2 2
输出样例1:
Stack
Queue

【耗时限制】1000ms 【内存限制】128MB

//
//Created by Carlgood.
//
//Note:This program is written in version DEV-C++ 5.11.
# include<iostream>
# include<cmath>
# include<string>
# include<cstring>
# include<cstdio>
# include<algorithm>
# include<sstream>
# include<iomanip>
# include<vector>
# include<queue>
# include<deque>
# include<stack>
# include<stdio.h>
# define This_program_is_written_by_Carlgood_Programming_Studio 9876543210
using namespace std;
const int STACK=1,QUEUE=2;
int main()
{
	int t,n,command,x,ans;
	cin>>t;
	while(t--)
	{
		cin>>n;
		stack<int> s;
		queue<int> q;
		for(int j=1;j<=n;j++)
		{
			cin>>command>>x;
			if(command==1)
			{
				s.push(x);
				q.push(x);
			}
			else
			{
				if(s.top()!=x)
				{
					ans=QUEUE;
				}
				else if(q.front()!=x)
				{
					ans=STACK;
				}
				s.pop();
				q.pop();
			}
		}
		if(ans==QUEUE)
		{
			cout<<"Queue\n";
		}
		else
		{
			cout<<"Stack\n";
		}
	}
	return 0;
}

  • 6
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值