PAT (Advanced Level) _1002 A+B for Polynomials

题目

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

多项式加法,建数组,下标做指数(exponents ),内容做系数(coefficients),下标相同的  内容相加减

AC代码

//多项式加法
#include<iostream>
#include<iomanip>
using namespace std;

const int N = 1001;

int main()
{
    double a[N] = {0};    //下标做指数,内容做系数
    double b[N] = {0};
    double sum[N] = {0};

    int ka,kb;
    int ksum = 0;
    cin>>ka;              //a的项数
    while(ka--){          //输入多项式a
        int m;
        double n;
        cin>>m>>n;
        a[m] = n;
    }                
    cin>>kb;              //b的项数
    while(kb--){          //输入多项式b
        int m;
        double n;
        cin>>m>>n;
        b[m] = n;
    }
    for(int i = 0; i<N; i++){        //下标相同的 内容相加减
        sum[i] = a[i] + b[i];
        if(sum[i] != 0)ksum++;       //计算和式的项数
    }
    cout<<ksum;                      //输出和式的项数
    for(int i = N-1; i>=0; i--){     //输出计算结果(按次数由大到小的顺序)
        //Please be accurate to 1 decimal place.    //注意保留一位小数
        if(sum[i] != 0)cout<<" "<<i<<" "<<fixed<<setprecision(1)<<sum[i];
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值