【杭电 5805 8.6 BC B NanoApe Loves Sequence】

NanoApe Loves Sequence

Problem Description
NanoApe, the Retired Dog, has returned back to prepare for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers on the paper and then randomly deleted a number in the sequence. After that, he calculated the maximum absolute value of the difference of each two adjacent remained numbers, denoted as F.

Now he wants to know the expected value of F, if he deleted each number with equal probability.

Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains an integer n, denoting the length of the original sequence.

The second line of the input contains n integers A1,A2,…,An, denoting the elements of the sequence.

1≤T≤10, 3≤n≤100000, 1≤Ai≤109

Output
For each test case, print a line with one integer, denoting the answer.

In order to prevent using float number, you should print the answer multiplied by n.

Sample Input
1
4
1 2 3 4

Sample Output
6

中文 :

问题描述
退役狗 NanoApe 滚回去学文化课啦!

在数学课上,NanoApe 心痒痒又玩起了数列。他在纸上随便写了一个长度为 nn 的数列,他又根据心情随便删了一个数,这样他得到了一个新的数列,然后他计算出了所有相邻两数的差的绝对值的最大值。

他当然知道这个最大值会随着他删了的数改变而改变,所以他想知道假如全部数被删除的概率是相等的话,差的绝对值的最大值的期望是多少。
输入描述
第一行为一个正整数 TT,表示数据组数。

每组数据的第一行为一个整数 nn。

第二行为 nn 个整数 A_iA
​i
​​ ,表示这个数列。

1 \le T \le 10,~3 \le n \le 100000,~1 \le A_i \le 10^91≤T≤10, 3≤n≤100000, 1≤A
​i
​​ ≤10
​9
​​
输出描述
对于每组数据输出一行一个数表示答案。

为防止精度误差,你需要输出答案乘上 nn 后的值。
输入样例
1
4
1 2 3 4
输出样例
6

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<stack>
#define INF 0x3f3f3f
#define K 100011
using namespace std;
int t,n;
long long pa[K];
long long id[K];
int cmp(long long a,long long b)
{
    return a>b;
}
int main()
{
     int i,j;
     long long ans;
     scanf("%d",&t);
     while(t--)
     {
         scanf("%d",&n);
         for(i=0;i<n;i++)
         scanf("%lld",&pa[i]);
         for(i=1;i<n;i++)
         id[i]=abs(pa[i]-pa[i-1]);
         id[0]=0;
         sort(id,id+n,cmp);
         ans=0;
        if(abs(pa[n-1]-pa[n-2])==id[0])
             ans+=id[1];
             else 
             ans+=id[0];
        if(abs(pa[1]-pa[0])==id[0])
             ans+=id[1];
             else
             ans+=id[0];
         for(i=1;i<n-1;i++)
         {
            if(abs(pa[i]-pa[i-1])==id[0])
             {
                if(abs(pa[i+1]-pa[i])==id[1])
                {
                if(abs(pa[i+1]-pa[i-1])>id[2])
                ans+=abs(pa[i+1]-pa[i-1]);
                else
                ans+=id[2];
                }
                else
                {
                    if(abs(pa[i+1]-pa[i-1])>id[1])
                    ans+=abs(pa[i+1]-pa[i-1]);
                    else
                    ans+=id[1]; 
                }
              } 
              else if(abs(pa[i+1]-pa[i])==id[0])
             {
                if(abs(pa[i]-pa[i-1])==id[1])
                {
                if(abs(pa[i+1]-pa[i-1])>id[2])
                ans+=abs(pa[i+1]-pa[i-1]);
                else
                ans+=id[2];
                }
                else
                {
                    if(abs(pa[i+1]-pa[i-1])>id[1])
                    ans+=abs(pa[i+1]-pa[i-1]);
                    else
                    ans+=id[1];
                }
              }
              else
              {
                if(abs(pa[i+1]-pa[i-1])>id[0])
                ans+=abs(pa[i+1]-pa[i-1]);
                else
                ans+=id[0];
              }
        }
         printf("%lld\n",ans);
    }
     return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值