【HDU 杭电 5773 The All-purpose Zero】

The All-purpose Zero

Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.

Sample Input
2
7
2 0 2 1 2 0 5
6
1 2 3 3 0 0

Sample Output
Case #1: 5
Case #2: 5

HintIn the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.

#include<cstdio>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
int pa[100011];
int st[100011];
int ma[100011];//建立一个全新的没有 0 的数组
int main()
{
    int i;
    int l;
    int T;
    int N;
    int num;
    int ans;
    int test=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        for(i=1;i<=N;i++)
            scanf("%d",&pa[i]);
            fill(st+1,st+1+N,INF);
            num=0;l=1;
        for(i=1;i<=N;i++)
        {
            if(pa[i]==0)//找出零的个数
                num++;
            else
            {
                pa[i]-=num;//减去当前 0 的个数
                ma[l++]=pa[i];
            }
        }
        ans=0;
        for(i=1;i<l;i++)
        {
            int k=lower_bound(st+1,st+1+N,ma[i])-st;
            st[k]=min(st[k],ma[i]);//更新尾数
            ans=max(ans,k);//更新最优解
        }
        printf("Case #%d: %d\n",test++,ans+num);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值