hdu 5773 贪心+最长上升子序列




链接:戳这里


The All-purpose Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 
Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 
Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 
Sample Input
2
7
2 0 2 1 2 0 5
6
1 2 3 3 0 0
 
Sample Output
Case #1: 5
Case #2: 5

Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.


思路:

看了题解。。。

对于ai为0的位置都取,因为0总是可以替换或者延长最长上升子序列。

现在考虑怎么样利用这些0,而且没有后效性。

这里题解的意思是直接把ai减去前面ai=0出现的个数,就不会多算的重复的数(这个贪心很强啊


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<string>
#include<vector>
#include <ctime>
#include<queue>
#include<set>
#include<map>
#include<stack>
#include<iomanip>
#include<cmath>
#include<bitset>
#define mst(ss,b) memset((ss),(b),sizeof(ss))
///#pragma comment(linker, "/STACK:102400000,102400000")
typedef long long ll;
#define INF (1ll<<60)-1
#define Max 1e9
using namespace std;
int sum[100100];
int a[100100],s[100100],vis[100100];
int main(){
    int T,n;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++){
        scanf("%d",&n);
        mst(vis,0);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        sum[0]=0;
        for(int i=1;i<=n;i++) {
            if(a[i]==0) sum[i]=sum[i-1]+1;
            else sum[i]=sum[i-1];
        }
        for(int i=1;i<=n;i++) {
            if(a[i]==0) {
                vis[i]=1;
                continue;
            }
            a[i]-=sum[i];
        }
        //for(int i=1;i<=n;i++) cout<<a[i]<<" ";cout<<endl;
        int ans=sum[n];
        int cnt=0;
        s[0]=-1e9;
        for(int i=1;i<=n;i++){
            if(vis[i]==1) continue;
            if(a[i]>s[cnt]) s[++cnt]=a[i];
            else {
                int x=lower_bound(s,s+cnt+1,a[i])-s;
                s[x]=a[i];
            }
        }
        //for(int i=0;i<=cnt;i++) cout<<s[i]<<" ";cout<<endl;
        ans+=cnt;
        printf("Case #%d: %d\n",cas,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值