【HDU 5944 Fxx and string】+ 优化

Fxx and string
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 424 Accepted Submission(s): 193

Problem Description
Young theoretical computer scientist Fxx get a string which contains lowercase letters only.

The string S contains n lowercase letters S1S2…Sn.Now Fxx wants to know how many three tuple (i,j,k) there are which can meet the following conditions:

1、i,j,k are adjacent into a geometric sequence.

2、Si=’y’,Sj=’r’,Sk=’x’.

3.Either j|i or j|k

Input
In the first line, there is an integer T(1≤T≤100) indicating the number of test cases.

T lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed 10000).

Output
For each case, output the answer.

Sample Input

2
xyyrxx
yyrrxxxxx

Sample Output

0
2

正反个判断一次~~~注意优化~~

AC代码 :

#include<bits/stdc++.h>
char st[10010];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
      int ans = 0;
      scanf("%s",st + 1);
      int nl = strlen(st + 1);
      for(int i = 1 ; i < nl ; i++)
        if(st[i] == 'y'){
            for(int j = i * 2 ; j < nl ; j += i)
                if(st[j] == 'r'){
                    int a = j / i * j;
                    if(a <= nl && st[a] == 'x')
                        ans++;
                }
            }
    for(int i = 1 ; i < nl ; i++)
        if(st[i] == 'x'){
            for(int j = i * 2 ; j < nl ; j += i)
                if(st[j] == 'r'){
                    int a = j / i * j;
                    if(a <= nl && st[a] == 'y')
                        ans++;
             }
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值