HDU5944——Fxx and string

37 篇文章 2 订阅

Fxx and string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 963    Accepted Submission(s): 399


Problem Description
Young theoretical computer scientist Fxx get a string which contains lowercase letters only.

The string  S  contains  n  lowercase letters  S1S2Sn .Now Fxx wants to know how many three tuple  (i,j,k)  there are which can meet the following conditions:

1、 i,j,k  are adjacent into a geometric sequence.

2、 Si= ' y ' ,Sj= ' r ' ,Sk= ' x '.

3.Either j|i or j|k
 

Input
In the first line, there is an integer  T(1T100)  indicating the number of test cases.

T  lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed  10000 ).
 

Output
For each case, output the answer.
 

Sample Input
  
  
2 xyyrxx yyrrxxxxx
 

Sample Output
  
  
0 2
 

Source

题意:
青年理论计算机科学家Fxx得到了一个只包含小写字母的字符串。

字符串的长度为\:nn,下标从1开始,第\:i\:i位的字母为\:s_isi,现在Fxx想知道有多少三元组\:(i,j,k)\:(i,j,k)满足下列条件

1、i,j,k\:i,j,k三个数成等比数列

2、s_i=si='yy',s_j=,sj='rr',s_k=,sk='xx'

3.i/ji/jk/jk/j中必须有整数
解:
根据题意直接对于 i,j,k三个变量进行打表操作,然后再字符串中根据已经得到的 i,j,k进行寻找并进行计数。注意反向同样适合规则。

#include <stdio.h>
#include <string.h>
#include <math.h>
char a[10005];
char b[10005];

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        getchar();
        while(n--)
        {
            memset(a,0,sizeof(a));
            gets(b);
            int len=strlen(b);
            int i,j,k;
            int count=0;
            for(int m=1;m<=len;m++)
            {
                a[m]=b[m-1];
            }
            for(int z=1;z<=sqrt(len);z++)
            {
                for(i=1;i<=len;i++)
                {
                    j=i*z;
                    k=j*z;
                    if(i<=len && j<=len && k<=len)
                    {
                        if(a[i]=='y' && a[j]=='r' && a[k]=='x')
                        {
                            count++;
                        }
                        if(a[i]=='x' && a[j]=='r' && a[k]=='y')
                        {
                            count++;
                        }
                    }
                }
            }
            printf("%d\n",count);
        }
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值