水题-fxx and string

Young theoretical computer scientist Fxx get a string which contains lowercase letters only. 

The string  S S contains  n n lowercase letters  S1S2Sn S1S2…Sn.Now Fxx wants to know how many three tuple  (i,j,k) (i,j,k) there are which can meet the following conditions: 

1、 i,j,k i,j,k are adjacent into a geometric sequence. 

2、 Si= Si=' y y' ,Sj= ,Sj=' r r' ,Sk= ,Sk=' x x'. 

3.Either j|i or j|k 
Input
In the first line, there is an integer  T(1T100) T(1≤T≤100) indicating the number of test cases. 

T T lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed  10000 10000). 
Output
For each case, output the answer.
Sample Input
2
xyyrxx
yyrrxxxxx
Sample Output
0

2

这个题大致意思是说找等比数列的序列 要考虑到程序的精简 注意不要超时,可以枚举比例,这个会节省很

多时间.

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
int main()
{
    int t;
    char a[10005];
    scanf("%d",&t);
    while(t--)
    {
        getchar();
        scanf("%s",a+1);
        int i,j,k;
        int num=0,l;
        l=strlen(a+1);
        for(i=1;i<=l;i++)
        {
           for(int bi=2;;bi++)
                  {
                       j=i*bi;
                       k=j*bi;
                       if(k>l)
                        break;
                       if(a[i]=='y'&&a[j]=='r'&&a[k]=='x')
                       num++;
                       if(a[i]=='x'&&a[j]=='r'&&a[k]=='y')
                        num++;
                  }
        }
        printf("%d\n",num);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值