Python:L1-064 估值一亿的AI核心代码 (20 分)

一、题目

在这里插入图片描述
以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I;
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 Ime 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don’t know

二、方法1

1、思路

本题运用了正则表达式

  1. 除去首尾的空格;
  2. 除去多余空格;
  3. 除去标点符号前的空格;
  4. 将 ? 替换为 !;
  5. 把除 I 以外的所以字符变为小写;
  6. 先分别存放 can I,could I 中的 can,could,再添加 you(将 I,me改为 you)。

2、代码

import re
for i in range(int(input())):
    str1=input()
    print(str1)
    print('AI: ', end='')
    str1=str1.strip()

    str1 = re.sub(r'(\s+)', ' ', str1)

    str3 = re.compile(r' +(\W)')
    str1 = str3.sub(r"\1", str1)

    str1 = re.sub('\?', '!', str1)

    for j in str1:
        if j != 'I':
            str1 = str1.replace(j, j.lower())

    str1 = re.sub(r'(\bcan you\b)', '_I can', str1)
    str1 = re.sub(r'(\bcould you\b)', '_I could', str1)
    str1 = re.sub(r'(\bI\b)', 'you', str1)
    str1 = re.sub(r'(\bme\b)', 'you', str1)
    str1 = re.sub(r'(\b_I\b)', 'I', str1)

    print(str1)
  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

WE-ubytt

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值