poj1386 Paly onWords

题目大意:给你很多单词,让你为这些单词排序,使这些单词每个单词首字母是上个单词的尾字母。

分析:对于每一个单词,我们只需要纪录下它的首字母和尾字母即可,然后单词接龙就变为了我们熟知的欧拉路径问题了。一个有向图存在欧拉路径,当且仅当该图是连通的,且所有顶点的出度和入度度数之和为0,或仅存在一个度数为1的顶点和一个度数为-1的顶点,其他顶点的度数为0。

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.
#include<string.h>
#include<stdio.h>
#define INF 0x3f3f3f3f
int T,n;
char word[1010];
int od[26],id[26];
int bu[26],f[26];
struct node
{
    int u,v;
}edge[100010];
void init()      //初始化
{
    for(int i=0;i<26;i++)
        f[i]=-1;
}
int findd(int x)    //判断两个点是否同为一个祖先
{
    int s;
    for(s=x;f[s]>=0;s=f[s])
        ;
    while(s!=x)
    {
        int tmp=f[x];
        f[x]=s;
        x=tmp;
    }
    return s;
}
void Union(int R1,int R2)  //合并子集
{
    int r1,r2;
    r1=findd(R1);
    r2=findd(R2);
    int tmp=f[r1]+f[r2];
    if(f[r1]>f[r2])
        {
            f[r1]=r2;
            f[r2]=tmp;
        }
        else
        {
            f[r2]=r1;
            f[r1]=tmp;
        }
}
int bconnect()   //判断有向图的基图是否联通
{
    int u,v,i;
    init();
    for(i=0;i<n;i++)
    {
        u=edge[i].u;
        v=edge[i].v;
        if(u!=v&&findd(u)!=findd(v))
            Union(u,v);
    }
    int first=-1;
    for(i=0;i<26;i++)
    {
        if(bu[i]==0)continue;
        if(first==-1)first=i;
        else if(findd(i)!=findd(first))break;
    }
    if(i<26)return 0;
    else return 1;
}
int main()
{
    int u,v,i,j;
    scanf("%d",&T);
    while(T--)
    {
        memset(od,0,sizeof(od));
        memset(id,0,sizeof(id));
        memset(bu,0,sizeof(bu));
        scanf("%d",&n);
        for(j=0;j<n;j++)
        {
            scanf("%s",word);
            u=word[0]-'a';v=word[strlen(word)-1]-'a';
            od[u]++;id[v]++;
            bu[u]=bu[v]=1;
            edge[j].u=u;edge[j].v=v;
        }
        int euler=1;
        int one=0;   //出度比入度多1 的个数
        int none=0;   //出度比入度少1的个数
        for(j=0;j<26;j++)
        {
            if(bu[j]==0)continue;
            if(od[j]-id[j]>=2||id[j]-od[j]>=2)
            {
                euler=0;break;
            }
            if(od[j]==0&&id[j]==0)
            {
                euler=0;break;
            }
            if(od[j]-id[j]==1)
            {
                one++;
                if(one>1)
                {
                    euler=0;break;
                }
            }
            if(id[j]-od[j]==1)
            {
                none++;
                if(none>1){euler=0;break;}
            }
        }
        if(one!=none)euler=0;
        if(!bconnect())euler=0;
        if(euler)printf("Ordering is possible.\n");
        else printf("The door cannot be opened.\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值