POJ - 3984 迷宫问题(BFS)

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)

(4, 4)

//一道简单搜素的题目,  主要就是利用BFS从起点开始搜索, 第一个到达终点的便是最短路径, 然后回溯输出路径。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <sstream>
#include <string>
#include <functional>
#define N 100100
using namespace std;
struct info
{
    int x;
    int y;
    int pre;//记录上一点路径
}que[110];//手动建一个简单队列
int i_way[] = {-1, 1, 0, 0};
int j_way[] = {0, 0, -1, 1};
int a[5][5];//记录矩阵
int vis[5][5];//标记是否被访问
void BFS();
int Front = 0;
int Rear = 1;
void Back(int n);//回溯
int main()
{
    for(int i = 0; i < 5; i++)
    {
        for(int j = 0; j < 5; j++)
        {
            scanf("%d", &a[i][j]);

        }
    }
    printf("(0, 0)\n");
    memset(vis, 0, sizeof(vis));
    BFS();
    printf("(4, 4)\n");
    return 0;
}
void BFS()
{
    que[Front].x = 0;
    que[Front].y = 0;
    que[Front].pre = -1;// 起点入队, 并标记
    while(Front < Rear)
    {
        for(int i = 0; i < 4; i++)
        {
            int nx = que[Front].x + i_way[i];
            int ny = que[Front].y + j_way[i];
            if(nx < 0 || ny < 0 || nx > 4 || ny > 4 || a[nx][ny] == 1 || vis[nx][ny] == 1)
            {
                continue;
            }
            else
            {
                vis[nx][ny] = 1;//标记被访问
                a[nx][ny] = 1;//防止路径返回, 将走过的点变为1
                que[Rear].x = nx;
                que[Rear].y = ny;
                que[Rear++].pre = Front;// 入队, 并记下上一点的位置
            }
            if(nx == 4 && ny == 4)
            {
                Back(Front);//到达终点, 回溯输出路径
            }
        }
        Front++;//出队
    }
}
void Back(int n)
{
    if(que[n].pre != -1)//一直回溯到标记的起点
    {
        Back(que[n].pre);
        printf("(%d, %d)\n", que[n].x, que[n].y);
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值