POJ 3984 迷宫问题(BFS)

题目链接:http://poj.org/problem?id=3984

题目大意:给定5*5的迷宫,求左上到右下最短路径,输出路径

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Source


思路:迷宫最短路,基本BFS,用两个prex[x][y]和prey[x][y]保存x,y点的前一个坐标,最后递归打印输出

代码:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<stack>

using namespace std;

#define FOU(i,x,y) for(int i=x;i<=y;i++)
#define FOD(i,x,y) for(int i=x;i>=y;i--)
#define MEM(a,val) memset(a,val,sizeof(a))
#define PI acos(-1.0)

const double EXP = 1e-9;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const ll MINF = 0x3f3f3f3f3f3f3f3f;
const int mod = 1e9+7;
const int N = 1e6+5;

int mp[6][6];
int vis[6][6];
int prex[6][6],prey[6][6];
int dir[4][2]={1,0,0,1,-1,0,0,-1};

struct node
{
    int x;
    int y;
};

void bfs()
{
    MEM(vis,0);
    node now,next;
    now.x=0,now.y=0;
    vis[now.x][now.y]=1;
    queue<node>q;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(now.x==4&&now.y==4)
            return ;
        for(int i=0;i<4;i++)
        {
            next.x=now.x+dir[i][0];
            next.y=now.y+dir[i][1];
            if(mp[next.x][next.y]==0&&vis[next.x][next.y]==0&&next.x>=0&&next.x<5&&next.y>=0&&next.y<5)
            {
                vis[next.x][next.y]=1;
                prex[next.x][next.y]=now.x;
                prey[next.x][next.y]=now.y;
                q.push(next);
            }
        }
    }
}

void output(int x,int y)
{
    if(x==0&&y==0)
        printf("(0, 0)\n");
    else
    {
        output(prex[x][y],prey[x][y]);
        printf("(%d, %d)\n",x,y);
    }
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    std::ios::sync_with_stdio(false);
    while(~scanf("%d",&mp[0][0]))
    {
        for(int i=1;i<5;i++)
            scanf("%d",&mp[0][i]);
        for(int i=1;i<5;i++)
            for(int j=0;j<5;j++)
                scanf("%d",&mp[i][j]);
        bfs();
        output(4,4);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值