POJ - 1860 Currency Exchange(SPFA最大路判断正环)

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题目大意:有多种汇币,汇币之间可以交换,这需要手续费,当你用100A币
交换B币时,A到B的汇率是29.75,手续费是0.39,那么你可以得到
(100 - 0.39) * 29.75 = 2963.3975 B币。问s币的金额经过交换最终
得到的s币金额数能否增加
货币的交换是可以重复多次的,所以我们需要找出是否存在
正权回路,且最后得到的s金额是增加的。

大体思路:
一种货币就是一个点。
一个“兑换点”就是图上两种货币之间的一个兑换方式,是双边,但A到B的汇率和手续费可能与B到A的汇率和手续费不同。
而A到B的权值为(V-Cab)*Rab。 得到一个由各种货币组成的“图”后,用SPFA法进行找最大路操作,所以dis数组初始化为0, dis[s]的初值为V。图中只要存在正环,SPFA算法就会一直跑,dis[s]就能不断增大。接下来判断是否存在正环有两种方法:一旦dis[s]增大, 则证明存在一个包括点S在内的正环。或者采用SPFA算法求最短路若一个点进队次数大于N(定点数),则存在负环这个结论。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#define N 120

using namespace std;
struct node
{
    int to;
    double rate;
    double cost;
}tmp;
vector <node> Map[N];
double dis[N];
bool vis[N];
int n, m, k;
double x;
bool SPFA(int s);

int main()
{
    while(cin >> n >> m >> k >> x)
    {
        int u, v;
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d", &u, &v);
            tmp.to = v;
            scanf("%lf%lf", &tmp.rate, &tmp.cost);
            Map[u].push_back(tmp);
            scanf("%lf%lf", &tmp.rate, &tmp.cost);
            tmp.to = u;
            Map[v].push_back(tmp);
        }
        if(SPFA(k))
        {
            cout << "YES" << endl;
        }
        else
        {
            cout << "NO" << endl;
        }
    }
}
bool SPFA(int s)
{
    memset(dis, 0, sizeof(dis));
    memset(vis, false, sizeof(vis));
    dis[s] = x;
    queue <int> q;
    q.push(s);
    vis[s] = true;
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        vis[u] = false;
        int _end = Map[u].size();
        for(int i = 0; i < _end; i++)
        {
            int to = Map[u][i].to;
            if(dis[to] < (dis[u] - Map[u][i].cost) * Map[u][i].rate)
            {
                dis[to] = (dis[u] - Map[u][i].cost) * Map[u][i].rate;
                if(dis[s] > x)
                return true;
                if(!vis[to])
                {
                    vis[to] = true;
                    q.push(to);
                }
            }
        }
    }
    return false;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值