Currency Exchange【最短路-fold判断正边权】

Currency Exchange

 POJ - 1860 

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3. 
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2. 
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4. 

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题目大意:第一行输入四个数n,m,S,V,分别代表钱的种类,换钱点的个数,手中拥有的钱的种类以及手中拥有的钱的数目,下面m行每行有六个数,前两个数代表a,b两种钱,后面四个小数前两个是将钱a换成钱b的汇率和佣金,后两个数代表b换成a的汇率和佣金。且钱a=Rab*(钱b-Cab)。

方法:因为判断最终前是否会增加,而每一个换钱点又可以重复使用,所以可以将每一个换钱点当做一个点,可以换钱则将两换钱点连起来构造成一个图,若能是最终的钱数增加,说明图中一定存在正环,所以可以用最短路的ford算法来实现,判断是否有正环,有就输出Yes,否则输出No。

AC代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
struct edge
{
	int u;
	int v;
	double R;
	double C;
}e[1000];
double dist[1000];
int m,n,S;
double V;
bool ford()
{
	dist[S]=V;
	for(int i=1;i<=m;i++)
	{
		bool ju=false;
		for(int j=0;j<2*n;j++)
		{
			int u=e[j].u;
			int v=e[j].v;
			double R=e[j].R;
			double C=e[j].C;
			if(dist[v]<R*(dist[u]-C))
			{
				ju=true;
				dist[v]=R*(dist[u]-C);
			}
		}
		if(!ju)
			return false;
	}
	for(int j=0;j<2*n;j++)
	{
		int u=e[j].u;
		int v=e[j].v;
		double R=e[j].R;
		double C=e[j].C;
		if(dist[v]<R*(dist[u]-C))
		{
			dist[v]=R*(dist[u]-C);
			return true;
		}
	}
	return false;
}
int main() 
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    scanf("%d %d %d %lf",&m,&n,&S,&V);
    int k=0;
    rep(i,1,n) {
    	int a,b;
    	double r1,c1,r2,c2;
    	scanf("%d %d %lf %lf %lf %lf",&a,&b,&r1,&c1,&r2,&c2);
    	e[k].u=a;
    	e[k].v=b;
    	e[k].R=r1;
    	e[k].C=c1;
    	k++;
    	e[k].u=b;
    	e[k].v=a;
    	e[k].R=r2;
    	e[k].C=c2;
    	k++;
    }
    bool ju=ford();
    if(ju)
    	printf("YES\n");
    else
    	printf("NO\n");
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值