文章标题 POJ 1151 : Atlantis (线段树+扫描线)

Atlantis

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
Input
The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.
The input file is terminated by a line containing a single 0. Don’t process it.
Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.
Output a blank line after each test case.
Sample Input
2
10 10 20 20
15 15 25 25.5
0
Sample Output
Test case #1
Total explored area: 180.00
题意:有n个矩形,然后要求出这n个矩形所覆盖的面积,每个矩形给出两个坐标就是左下角和右上角的两个坐标。
分析:线段树扫描线的模板题,利用线段树的扫描线求面积并。
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>

using namespace std;

const double pi=acos(-1.0);
const int inf = 0x3f3f3f3f;
const int maxn=205;
const double eps=1e-8; 
int n;
struct segment {//线段 
    double l,r,h;
    int flag;
    segment(){}
    segment(double l_,double r_,double h_,int flag_){
        l=l_;r=r_;h=h_;flag=flag_;
    }
    bool operator < (const segment &t)const {//按当前线段从低到高排序 
         return h<t.h;
    } 
}s[maxn]; 
int lazy[maxn<<2];
double sum[maxn<<2];
double hash[maxn<<2];

void push_up(int rt,int l,int r){//向上更新 
    if (lazy[rt]) sum[rt]=hash[r+1]-hash[l];
    else if (l==r) sum[rt]=0;
    else sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void update (int rt,int L,int R,int ql,int qr,int flag){
    if (ql<=L&&R<=qr){
        lazy[rt]+=flag;
        push_up(rt,L,R);
        return ;
    }   
    int mid=(L+R)>>1;
    if (ql<=mid)update(2*rt,L,mid,ql,qr,flag);
    if (qr>mid)update(2*rt+1,mid+1,R,ql,qr,flag);
    push_up(rt,L,R);
}
int main()
{
    double x1,x2,y1,y2;
    int temp=1;
    while (scanf ("%d",&n)&&n){
        int k=0;
        for(int i = 0 ; i < n ; i++){
            scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
            hash[k]=x1;//保存x坐标 
            s[k++]=segment(x1,x2,y1,1);//1表示为下边 
            hash[k]=x2;
            s[k++]=segment(x1,x2,y2,-1);//-1表示为上边 
        } 
        sort(hash,hash+k);//排序 
        sort(s,s+k);

        int m=1;
        for (int i=1;i<k;i++){//去重点 
            if (hash[i]!=hash[i-1]){
                hash[m++]=hash[i];
            }
        }
        double ans=0;
        for (int i=0;i<k;i++){
            int L=lower_bound(hash,hash+m,s[i].l)-hash;//表示第几个节点 
            int R=lower_bound(hash,hash+m,s[i].r)-hash-1;
            update(1,0,m-1,L,R,s[i].flag);//更新 
            ans+=sum[1]*(s[i+1].h-s[i].h);//每次将面积加起来 
        }
        printf("Test case #%d\nTotal explored area: %.2f\n\n", temp++, ans);
    }
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值