文章标题 HDU 3530 : Subsequence(单调队列)

Subsequence

There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range 1,1000001,100000. m and k are in the range 0,10000000,1000000. The second line has n integers, which are all in the range 0,10000000,1000000.
Proceed to the end of file.
Output
For each test case, print the length of the subsequence on a single line.
Sample Input
5 0 0
1 1 1 1 1
5 0 3
1 2 3 4 5
Sample Output
5
4
题意:有n个数的序列,然后给出数m,k,然后要我们求出这个n个序列中的最长子序列,使得这个序列满足最大值与最小值的查值大于m且小于k。
分析:用单调队列,用两个队列,一个单调上升,一个单调下降。来维护当前的序列的最大值与最小值,然后当出现不满足的情况的时候应该从那个位置值小的来维护,然后更新答案即可。
代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue> 
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
typedef pair<int,int> pii;

int n,m,k; 
int a[100005];
int q1[100005],q2[100005];//q1单调上升队列,q2单调下降队列,保存的是位置 
int rear1,rear2;
int head1,head2;

int main ()
{
    while (scanf ("%d%d%d",&n,&m,&k)!=EOF){
        rear1=rear2=0;
        head1=head2=0;
        int ans=0;
        int now=1;
        for (int i=1;i<=n;i++){
            scanf ("%d",&a[i]);
            while (head1<rear1&&a[q1[rear1-1]]<a[i])rear1--;//降序 
            while (head2<rear2&&a[q2[rear2-1]]>a[i])rear2--;//升序
            q1[rear1++]=i;
            q2[rear2++]=i;
            while (head1<rear1&&head2<rear2&&a[q1[head1]]-a[q2[head2]]>k){
                //当最值之间的差值超过了k,应该在那个位置小的先移动 
                if (q1[head1]<q2[head2])now=q1[head1++]+1;
                else now=q2[head2++]+1;
            }
            if (head1<rear1&&head2<rear2&&a[q1[head1]]-a[q2[head2]]>=m){
                ans=max(ans,i-now+1);//更新答案 
            }
        }
        printf ("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值