1005 Spell It Right (20)(20 分)

 

目录

 

题目:

反思:

代码: 


题目:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

反思:

N的取值非常大,不能直接用int

代码: 

#include<iostream>
#include<iomanip>
#include<algorithm>
#include<vector>
#include<queue>
#include<string>
#include<map>
#include<list>
#include<set>
using namespace std;
int main()
{
	int n = 0, i = 0;
	string s, change[10] = { "zero","one","two","three","four","five","six","seven","eight","nine" };
	cin >> s;
	for (i = 0; i < s.size(); i++)n += s[i] - '0';
	s = to_string(n);
	for (i = 0; i < s.size(); i++)
	{
		if (i)cout << ' ';
		cout << change[s[i] - '0'];
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值