1009 Product of Polynomials (25)(25 分)

目录

题目:

反思:

代码:


题目:

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ ... NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 3 3.6 2 6.0 1 1.6

反思:

多项式相乘后有可能某一项系数为零,记得要从总项数中减去,并不能输出

代码:

#include<iostream>
#include<iomanip>
#include<functional>
#include<algorithm>
#include<vector>
#include<queue>
#include<string>
#include<map>
#include<list>
#include<set>
using namespace std;
int main()
{
	int k, a, i;
	double x;
	map<int, double> result, one;
	cin >> k;
	for (i = 0; i < k; i++)
	{
		cin >> a >> x;
		one[a] = x;
	}
	cin >> k;
	for (i = 0; i < k; i++)
	{
		cin >> a >> x;
		for (map<int, double>::iterator it = one.begin(); it != one.end(); it++)
		{
			if (result.count(a + it->first) == 0)result[a + it->first] = x * it->second;
			else result[a + it->first] += x * it->second;
			if (result[a + it->first] == 0)result.erase(a + it->first);
		}
	}
	cout << result.size();
	for (map<int, double>::reverse_iterator it1 = result.rbegin(); it1 != result.rend(); it1++)
		cout << ' ' << it1->first << ' ' << fixed << setprecision(1) << it1->second;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值