1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1a​N1N​2a​N2… N​Ka​N​K
where K is the number of nonzero terms in the polynomial, N​iand a​N​i
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K<⋯<N2<N​1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
1.不用将两个多项式都存起来
2.第一个测试点有0项,要删除,不用输出0.
3.没有指数为小数的情况

#include<iostream>
#include<vector>
#include<map>
using namespace std;
int main()
{
	int n, exponents;
	double  coefficients;
	map<int, double,greater<int>>re;
	cin >> n;
	vector < vector<double> > Polynomials(n, vector<double>(2));
	for (int i = 0; i < n; i++)
		for (int j = 0; j < 2; j++)
			cin >> Polynomials[i][j];
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> exponents >> coefficients;
		for (int j = 0; j < Polynomials.size(); j++)
			re[exponents + Polynomials[j][0]] += coefficients * Polynomials[j][1];
	}
	for (auto it : re)
		if (it.second == 0)
			re.erase(it.first);
	printf("%d", re.size());
	for (auto it :re)
		printf(" %d %.1f", it.first, it.second);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值