1009 Product of Polynomials (25 分)【模拟多项式乘法】

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 3 3.6 2 6.0 1 1.6

本题要求模拟多项式A和多项式B的乘法
思路直接开两个大小大于1000的数组存储多项式A和B
其中数组下标代表指数,数组元素存储系数
注意结果数组C的大小要大于2000,以为A,B中指数的最大值为1000,相乘后的值不大于2000
然后两层for循环遍历得到结果集C

#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
    double A[1020]={0.0};
    double B[1020]={0.0};
    double C[2020]={0.0};
    int ka,kb;
    cin>>ka;
    for(int i = 0;i<ka;i++)
    {
        int nk;
        double a;
        cin>>nk>>a;
        A[nk] = a;
    }
    cin>>kb;
    for(int i = 0;i<kb;i++)
    {
        int nk;
        double a;
        cin>>nk>>a;
        B[nk] = a;
    }
    for(int i=0;i<=1000;i++)
        for(int j=0;j<=1000;j++)
        {
            C[i+j]+=A[i]*B[j];
        }
    int count = 0;
    for(int i=0;i<=2000;i++)
        if(C[i]!=0.0)
            count++;
    cout<<count;
    for(int i = 2000;i>=0;i--)
        if(C[i]!=0.0){
            cout<<" "<<i<<" ";
            printf("%.1lf",C[i]);
        }
    return 0;
}
  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值