HDU 5943 - Kingdom of Obsession(二分图)


Kingdom of Obsession

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 780    Accepted Submission(s): 211


Problem Description
There is a kindom of obsession, so people in this kingdom do things very strictly.

They name themselves in integer, and there are n people with their id continuous (s+1,s+2,,s+n) standing in a line in arbitrary order, be more obsessively, people with id x wants to stand at yth position which satisfy

xmody=0


Is there any way to satisfy everyone's requirement?
 

Input
First line contains an integer T , which indicates the number of test cases.

Every test case contains one line with two integers n , s .

Limits
1T100 .
1n109 .
0s109 .
 

Output
For every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the result string.

If there is any way to satisfy everyone's requirement, y equals 'Yes', otherwise y equals 'No'.
 

Sample Input
  
  
2 5 14 4 11
 

Sample Output
  
  
Case #1: No Case #2: Yes
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6010  6009  6008  6007  6006 
 


/*
 题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=5943

题目大意:
  给定S,N,把S+1,S+2,...S+N这N个数填到1,2,...,N里,要求X只能填到X的因子的位置。
    (即X%Y=0,那么X才能放在Y位置)
    问是否能够放满。

题目思路:  【二分图匹配 匈牙利算法】

首先,如果S<N,那么S+1,S+2...N这些数直接放在S+1,S+2...N的位置上
(如果其他数x放在这些位置上面,这些数不放在对应位置,那么x一定能放在这些数放的位置,所以直接交换即可)
所以可以直接将S和N调换,缩小N。
接着看N个连续的数,如果出现2个素数。那么必然无解(都只能放1)
所以可以估算一下素数的最大间隔(我取504),N超过必然无解。
N小于504的情况下,直接暴力建边(能整除就连边),然后跑二分图匹配即可。

摘自:http://blog.csdn.net/u010568270/article/details/52965762

*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <sstream>
#include <map>
#include <set>
#define pi acos(-1.0)
#define LL long long
#define ULL unsigned long long
#define inf 0x3f3f3f3f
#define INF 1e18
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
typedef pair<int, int> P;
const double eps = 1e-10;
const int maxn = 1e6 + 5;
const int N = 1e4 + 5;
const int mod = 1e8;

vector<int>G[N];
int vis[N], link[N], n, s;

bool dfs(int u)
{
    vis[u] = 1;
    for (int i = 0; i < G[u].size(); i++){
        int v = G[u][i];
        if (!vis[v]){
            vis[v] = 1;
            if (link[v] == -1 || dfs(link[v])){
                link[v] = u;
                return true;
            }
        }
    }
    return false;
}
int Match()
{
    memset(link, -1, sizeof(link));
    int ans = 0;
    for (int i = 1; i <= n; i++){
        memset(vis, 0, sizeof(vis));
        if (dfs(i)) ans++;
    }
    return ans;
}
int main(void)
{
//	freopen("in.txt","r", stdin);
    int T, cas = 1;
    cin >> T;
    while (T--)
    {
        cin >> n >> s;
        if (s < n) swap(n, s);// 不交换过不了。。。。。
        if (n > 555){
            printf("Case #%d: No\n", cas++);
            continue;
        }
        memset(G, 0, sizeof(G));
        for (int i = 1; i <= n; i++){
            for (int j = 1; j <= n; j++){
                if ((i+s) % j == 0){
//                    G[i+n].push_back(j); //可以为单向,也可以双向
                    G[j].push_back(i+n);
                }
            }
        }
        if (Match() != n)
            printf("Case #%d: No\n", cas++);
        else printf("Case #%d: Yes\n", cas++);
    }

	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值